• Wildfly, security domain

    Hello,   I am trying to deploy a login scream on my wildfly application (16) but i got this error on deploy:   server-one" => {   "WFLYCTL0412: Required services that are not installed:" => ["...
    Profile Photo
    last modified by Lucas Meante
  • Modules inside domain folder

    Hello everybody. My short question is: is it possible to install some jboss module inside a domain folder (say C:\EAP-7.2.0\standalone\modules ), instead than in the main jboss folder (say C:\EAP-7.2.0\modules) ? ...
    Profile Photo
    created by luca vercelli
  • Aborting with 1 threads active

    Hi, from time to time our log file ends with WARN : [com.arjuna.ats.arjuna.coordinator.BasicAction_58] - Abort of action id 7f000002:a108:48b40e06:282b06e invoked while multiple threads active within it. WARN : [com....
    Profile Photo
    last modified by Jana -
  • WildFly 18 : Change in redirect behavior after upgrading from WildFly 17

    Hello !   After uprgading from WildFly 17.0.1 to WildFly 18.0.1, we saw a change in the way the WildFly replies to an HTTP request to the /application (without trailing slash) URL. Reviewing the changelog did n...
    Profile Photo
    last modified by David Le Borgne
  • WildFly Client Remoting - Use Mutual Authentication (SSL) - How to configure?

    Hi,   I have a requirement to use Mutual Authentication for WildFly Client to authenticate with the WildFly server to execute Remote EJB invocations. I am using WildFly 18 and trying to enhance the quickstart "e...
    Profile Photo
    last modified by KGA Official
  • linux eclipse wildfly deployment stuck at startup

    Hi All, I am trying to deploy and start wildfly from eclipse. This has been working for me just fine on windows. I just switched to linux mint and cant get this working. It seems to me that deployment scanner is not ...
    Profile Photo
    last modified by oğuz karakuş
  • BeanIO Reader with Validation

    My bean has annotations for a field to not be null. It works -   2019-11-11 14:38:41.860 jberet-1                   ...
    Profile Photo
    last modified by Richard Moore
  • non-existant column 'mode:localName' in '__ALLNODES__'

    Let me start by saying that I am totally new to JCR and ModeShape. I am just playing around a little. And I got a weird error.   The statements:   Query q = ses.getWorkspace().getQueryManager().createQuery...
    Profile Photo
    last modified by Arne Vajhoej
  • keycloak jboss not able to connect to mysql

    I am trying to use mysql for keycloak and have used the same config before but this time it is giving a link failure. volumes:   mysql_data:   driver: local services:   mysql:   image: mysql:5.7 &...
    Profile Photo
    last modified by karan shah
  • Too many intra-process localhost connections

    Hi!   I'm observing many localhost connections. The number of connections keeps increasing leading wildfly to just log connection problems because Windows runs out of available ports:   Log entry example ...
    Profile Photo
    last modified by Luís M. Costa
  • WildFly 18: JGroups: No such method error

    We are using embedded infinispan jars. The same configuration was working on 17.0.1.Final.   11:32:01,280 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 79) MSC000001: Failed to start service j...
    Profile Photo
    last modified by Tom Stiemerling
  • Get OAUTH introspection response from Elytron

    We are using bearer token authentication feature in WildFly to protect a REST API. The authentication works, but we need to get access to the whole introspection response that comes back from the IDP. How can this be ...
    Profile Photo
    created by Tom Stiemerling
  • Byteman stops working when there are more than 3 JSF applications deployed to JBoss

    Hi,   My byteman script works when there is one application with JSF 1.2 deployed to JBoss, I can see the logging. However, customer told me that the scripts work up to 3 different JSF applications were deployed...
    Profile Photo
    last modified by Lei Yu
  • wsconsume not picking up -w ?

    I'm trying to generate JAX-WS-artifacts but I'm unable to set the wsdlLocation on the @WebServiceClient. I use -w WEB-INF/wsdl/foo.wsdl but I always end up with the annotation attribute wsdlLocation="foo.wsdl". I see ...
    Profile Photo
    last modified by Nicklas Karlsson
  • Multiple security domains in Elytron

    We are currently switching from PicketBox security to Elytron (on EAP 7.2). Now we've got a problem with one of our ear deployments configuring two different security domains in jboss-ejb3.xml. We get "WFLYEJB0490: M...
    Profile Photo
    last modified by Gerret Hansper
  • How we can add JacORB in wildfly

    Hi, I am migrating my app from JBOSS -7.0.1 to wildfly-17.0.1. I have some code which uses JacORB and I want to use same code with little modification in wildfly-17.0.1. While doing this, I am getting following err...
    Profile Photo
    last modified by Manish Jain
  • Arquillian and PostgreSQL driver

    Hello! I try to use Arquillian with TomEE and connection to PostgreSQL database but when I run test, it fail becouse server cannot find "org.postgresql.Driver": ... 13-Nov-2019 16:57:46.469 SEVERE [main] org.apache...
    Profile Photo
    last modified by Alexey Makarov
  • Upgrade to Infinispan 10

    Hello,   Is it planned to upgrade Wildfly to use Infinispan 10? When would that be available? I'm currently hitting a bug which is solved only in the 10.x release series.   Thank you very much,   Juan
  • Activemq remote JMS Connection does not working

    Hi,   I am using wildfly 14 server  and activemq for JMS remote server communication.  I am getting  an error during remote jms communication( AMQ214016: Failed to create netty connection: javax.n...
    Profile Photo
    last modified by MeenakshiSundaram R
  • Accessing JDK classes in WF18

    I'm customizing some JAXB-encoding and have a custom CharacterEscapeHandler but on deployment I get a   java.lang.ClassNotFoundException: com.sun.xml.bind.marshaller.CharacterEscapeHandler  even if I have a...
    Profile Photo
    last modified by Nicklas Karlsson