5 Replies Latest reply on Feb 16, 2003 4:33 PM by juhalindfors

    Installation on Debian

    Rob Pumphrey Newbie

      I have installed JBoss onto an Linux machine running Debian. JBoss fails to start with the following mesages in the stdout

      jboss@exeters01:/export/opt/JBoss/bin$ ./run.sh
      ================================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /export/opt/JBoss

      JAVA: /export/opt/jdk/bin/java

      JAVA_OPTS: -server -Dprogram.name=run.sh

      CLASSPATH: /export/opt/JBoss/bin/run.jar:/export/opt/jdk/lib/tools.jar

      ================================================================================

      java.lang.NoClassDefFoundError: javax/management/MalformedObjectNameException
      at org.jboss.system.server.ServerImpl.(ServerImpl.java:51)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
      at java.lang.Class.newInstance0(Class.java:296)
      at java.lang.Class.newInstance(Class.java:249)
      at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:244)
      at org.jboss.system.server.ServerLoader.load(ServerLoader.java:224)
      at org.jboss.Main.boot(Main.java:140)
      at org.jboss.Main$1.run(Main.java:381)
      at java.lang.Thread.run(Thread.java:536)



      JVM version 1.4.0

      I have got this to run on other Linux boxes without any problem. This just appears to be a blocker for me on Debian. Any suggestions??

      Thanks