2 Replies Latest reply: Jun 22, 2012 5:10 AM by technokrat RSS

    New missing/unsatisfied dependencies in curren migration from JBoss 6.1.0 to JBoss 7.1.0

    technokrat Newbie

      Hi, I have problem with deploying application.

       

       

      jboss-deployment-structure:

      <jboss-deployment-structure>

          <ear-subdeployments-isolated>false</ear-subdeployments-isolated>

          <deployment>

                    <dependencies>

                                <!--module name="javax.api" export="true"/-->

                                 <module name="org.apache.log4j" export="true" />

                        <module name="org.hibernate" slot="3" export="true" />

                        <module name="defgo_libs" export="true"/>

                        <module name="deployment.module.hibernate-utils" export="true"/>

                        <module name="deployment.module.defgo-utils" export="true"/>

             </dependencies>

          </deployment>

          <sub-deployment name="logger.jar"/>

          <sub-deployment name="benchmark.jar"/>

       

       

                    <module name="deployment.module.hibernate-utils">

                                              <resources>

                                                        <resource-root path="hibernate-utils.jar"/>

                                              </resources>

                                    </module>

                                    <module name="deployment.module.defgo-utils">

                                              <resources>

                                                        <resource-root path="defgo-utils.jar"/>

                                              </resources>

                                    </module>

      </jboss-deployment-structure>

       

      Benchmark jboss-ejb3.xml:

      <?xml version="1.0"?>

      <jboss:ejb-jar xmlns:jboss="http://www.jboss.com/xml/ns/javaee"

                     xmlns="http://java.sun.com/xml/ns/javaee"

                     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

                     xsi:schemaLocation="http://www.jboss.com/xml/ns/javaee http://www.jboss.org/j2ee/schema/jboss-ejb3-2_0.xsd

                           http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/ejb-jar_3_1.xsd"

                     version="3.1"

                     impl-version="2.0">

          <enterprise-beans>

              <session>

                  <description>Unit data access object</description>

                  <display-name>Unit Accessor</display-name>

                  <ejb-name>UnitAccessor</ejb-name>

                  <ejb-class>net.defgo.benchmark.hierarchy.impl.UnitDAO</ejb-class>

                  <session-type>Stateless</session-type>

                  <transaction-type>Container</transaction-type>

              </session>

              <session>

                  <description>UnitStatistic data access object</description>

                  <display-name>UnitStatistic Accessor</display-name>

                  <ejb-name>UnitStatisticAccessor</ejb-name>

                  <ejb-class>net.defgo.benchmark.hierarchy.impl.UnitStatisticDAO</ejb-class>

                  <session-type>Stateless</session-type>

                  <transaction-type>Container</transaction-type>

              </session>

              <session>

                  <description>Business interface for hierarchy</description>

                  <display-name>Business Hierarchy</display-name>

                  <ejb-name>BusinessHierarchy</ejb-name>

                  <ejb-class>net.defgo.benchmark.hierarchy.impl.BusinessHierarchyBean</ejb-class>

                  <session-type>Stateless</session-type>

                  <transaction-type>Container</transaction-type>

              </session>

          </enterprise-beans>

      </jboss:ejb-jar>

       

      Logger jboss-ejb3.xml:


      <?xml version="1.0"?>

      <ejb-jar xmlns="http://java.sun.com/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

      xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/ejb-jar_3_0.xsd"

      version="3.0">

          <enterprise-beans>

              <session>

                  <description>Logger data access object</description>

                  <display-name>LogAccessor</display-name>

                  <ejb-name>LogAccessor</ejb-name>

                  <ejb-class>net.defgo.logger.impl.LogDAO</ejb-class>

                  <session-type>Stateless</session-type>

                  <transaction-type>Container</transaction-type>

              </session>

              <session>

                  <description>Write diary log</description>

                  <display-name>DiaryLoggerBean</display-name>

                  <ejb-name>DiaryLoggerBean</ejb-name>

                  <ejb-class>net.defgo.logger.impl.DiaryLoggerBean</ejb-class>

                  <session-type>Stateless</session-type>

                  <transaction-type>Container</transaction-type>

              </session>

       

       

              <message-driven>

                <description>Write diary log</description>

                <display-name>LogWriterBean</display-name>

                <ejb-name>LogWriter</ejb-name>

                <ejb-class>net.defgo.logger.impl.LogWriter</ejb-class>

                <messaging-type>javax.jms.MessageListener</messaging-type>

                <transaction-type>Container</transaction-type>

                <message-destination-type>javax.jms.Queue</message-destination-type>

                <activation-config>

                    <activation-config-property>

                        <activation-config-property-name>destinationType</activation-config-property-name>

                        <activation-config-property-value>javax.jms.Queue</activation-config-property-value>

                    </activation-config-property>

                    <activation-config-property>

                        <activation-config-property-name>destination</activation-config-property-name>

                        <activation-config-property-value>queue/LogQueue</activation-config-property-value>

                    </activation-config-property>

                    <activation-config-property>

                        <activation-config-property-name>subscriptionDurability</activation-config-property-name>

                        <activation-config-property-value>Durable</activation-config-property-value>

                    </activation-config-property>

                    <activation-config-property>

                        <activation-config-property-name>acknowledgeMode</activation-config-property-name>

                        <activation-config-property-value>Auto-acknowledge</activation-config-property-value>

                    </activation-config-property>

                </activation-config>

                <!--resource-ref>

                    <res-ref-name>java:/ConnectionFactory</res-ref-name>

                    <res-type>javax.jms.QueueConnectionFactory</res-type>

                    <res-auth>Container</res-auth>

                </resource-ref-->

            </message-driven>

        </enterprise-beans>

      </ejb-jar>

       

      JBoss writes about missing/unavailable dependents. But I can't find which dependents and how I can fix it.
      The part of log is:

      "15:47:05,019 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS015870: Deploy

      of deployment "defgo.ear" was rolled back with failure message {"JBAS014771: Services with m

      issing/unavailable dependencies" => ["jboss.naming.context.java.comp.defgo.benchmark.UnitSta

      tisticAccessor.ORBjboss.naming.context.java.comp.defgo.benchmark.UnitStatisticAccessorMissin..."

       

      Detailed log see in server.log.

       

      boot.log isn't informative, I set log level to TRACE for finding problem with JAXP, but I didn't find.

        • 1. Re: New missing/unsatisfied dependencies in curren migration from JBoss 6.1.0 to JBoss 7.1.0
          Scott Marlow Master

          I looked at your attached server.log.  The first important error, is that about a syntax error in your jboss-deployment-structure.xml.  See if you can fix that first.

          07:55:42,975 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC00001: Failed to start service jboss.deployment.unit."defgo.ear".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."defgo.ear".STRUCTURE: Failed to process phase STRUCTURE of deployment "defgo.ear"

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_31]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_31]

              at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_31]

          Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: Error loading jboss-structure.xml from C:\jboss-as-7.1.1.Final\standalone\tmp\vfs\temp6faff18fe8b1c336\defgo.ear-3a8399ce403bb3e9\contents\META-INF\jboss-deployment-structure.xml

              at org.jboss.as.server.deployment.module.descriptor.DeploymentStructureDescriptorParser.parse(DeploymentStructureDescriptorParser.java:277) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.as.server.deployment.module.descriptor.DeploymentStructureDescriptorParser.parse(DeploymentStructureDescriptorParser.java:249) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.as.server.deployment.module.descriptor.DeploymentStructureDescriptorParser.deploy(DeploymentStructureDescriptorParser.java:134) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              ... 5 more

          Caused by: com.ctc.wstx.exc.WstxParsingException: Unexpected '<'  in attribute value

          at [row,col {unknown-source}]: [56,13]

              at com.ctc.wstx.sr.StreamScanner.constructWfcException(StreamScanner.java:606)

              at com.ctc.wstx.sr.StreamScanner.throwParseError(StreamScanner.java:479)

              at com.ctc.wstx.sr.StreamScanner.throwParseError(StreamScanner.java:464)

              at com.ctc.wstx.sr.BasicStreamReader.parseAttrValue(BasicStreamReader.java:1921)

              at com.ctc.wstx.sr.BasicStreamReader.handleNsAttrs(BasicStreamReader.java:3028)

              at com.ctc.wstx.sr.BasicStreamReader.handleStartElem(BasicStreamReader.java:2926)

              at com.ctc.wstx.sr.BasicStreamReader.nextFromTree(BasicStreamReader.java:2802)

              at com.ctc.wstx.sr.BasicStreamReader.next(BasicStreamReader.java:1050)

              at com.ctc.wstx.sr.BasicStreamReader.nextTag(BasicStreamReader.java:1125)

              at org.jboss.staxmapper.XMLExtendedStreamReaderImpl.nextTag(XMLExtendedStreamReaderImpl.java:152) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

              at org.jboss.as.server.deployment.module.descriptor.JBossDeploymentStructureParser11.parseDependencies(JBossDeploymentStructureParser11.java:386) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.as.server.deployment.module.descriptor.JBossDeploymentStructureParser11.parseModuleStructureSpec(JBossDeploymentStructureParser11.java:316) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.as.server.deployment.module.descriptor.JBossDeploymentStructureParser11.parseSubDeployment(JBossDeploymentStructureParser11.java:260) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.as.server.deployment.module.descriptor.JBossDeploymentStructureParser11.readElement(JBossDeploymentStructureParser11.java:214) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.as.server.deployment.module.descriptor.JBossDeploymentStructureParser11.readElement(JBossDeploymentStructureParser11.java:42) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

              at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

              at org.jboss.as.server.deployment.module.descriptor.DeploymentStructureDescriptorParser.parse(DeploymentStructureDescriptorParser.java:271) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              ... 8 more

           

          • 2. Re: New missing/unsatisfied dependencies in curren migration from JBoss 6.1.0 to JBoss 7.1.0
            technokrat Newbie

            Hi, Scott, sorry for too old log. This erroer in jboss-deployment-structure was fixed.

             

            In this atachment is actual log, without old error.