1 Reply Latest reply on Jul 13, 2006 4:31 AM by mmm jjj

    deployment exception

    mmm jjj Newbie

      Hi,
      during deployment following exception occurs:

      15:28:35,265 ERROR [MainDeployer] Could not create deployment: file:/C:/jboss-4.0.4.GA/server/default/tmp/deploy/tmp50144ws2.ear-content
      s/ws2_ejb.jar
      java.lang.NullPointerException
       at org.jboss.ws.server.WebServiceDeployerEJB21.createWebServicesMetaData(WebServiceDeployerEJB21.java:149)
       at org.jboss.ws.server.WebServiceDeployer.create(WebServiceDeployer.java:103)
       at org.jboss.deployment.SubDeployerInterceptorSupport$XMBeanInterceptor.create(SubDeployerInterceptorSupport.java:180)
       at org.jboss.deployment.SubDeployerInterceptor.invoke(SubDeployerInterceptor.java:91)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
       at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
       at $Proxy26.create(Unknown Source)
       at org.jboss.deployment.MainDeployer.create(MainDeployer.java:953)
       at org.jboss.deployment.MainDeployer.create(MainDeployer.java:943)
       at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:807)
       at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:771)
       at sun.reflect.GeneratedMethodAccessor55.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
       at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
       at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
       at $Proxy8.deploy(Unknown Source)
       at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:421)
       at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:634)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:263)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.loop(AbstractDeploymentScanner.java:274)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeploymentScanner.java:225)
      


      My configuration:
      <configuration xmlns="http://www.jboss.org/jbossws-tools">
       <java-wsdl>
       <service name="CService" style="document" endpoint="ejb.ClientEndPoint" />
       <namespaces target-namespace="http://ejb/" type-namespace="http://ejb/types" />
       <mapping file="mapping.xml" />
       <webservices ejb-link="CService" />
       </java-wsdl>
      </configuration>
      


      And generated webservices.xml


      <webservices version='1.1' xmlns='http://java.sun.com/xml/ns/j2ee' xmlns:impl='http://ejb/'
       xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'
       xsi:schemaLocation='http://java.sun.com/xml/ns/j2ee http://www.ibm.com/webservices/xsd/j2ee_web_services_1_1.xsd'>
       <webservice-description>
       <webservice-description-name>CServices</webservice-description-name>
       <wsdl-file>META-INF/wsdl/CServices.wsdl</wsdl-file>
       <jaxrpc-mapping-file>META-INF/mapping.xml</jaxrpc-mapping-file>
       <port-component>
       <port-component-name>ClientEndPointPort</port-component-name>
       <wsdl-port>impl:ClientEndPointPort</wsdl-port>
       <service-endpoint-interface>ejb.ClientEndPoint</service-endpoint-interface>
       <service-impl-bean>
       <ejb-link>ClientBean</ejb-link>
       </service-impl-bean>
       </port-component>
       </webservice-description>
      </webservices>



      What can be the cause of the problem ?

      Thanks,

      Mttu