0 Replies Latest reply on Sep 25, 2006 6:10 PM by Gerhard Otte

    Problem with XB Bindigs

    Gerhard Otte Newbie

      Hello !

      I have a problem with the XB bindings. I'm using JBoss 4.0.4 GA and JBossWS 1.0.3 and manually replaced the jboss-xb-bindings.jar as described in the installation.
      I generated the wsdl and other atifacts by wstools wit the following configuration:

      <configuration>
       <java-wsdl>
       <service name="ShipmentService" style="document" parameter-style="bare"
       endpoint="de.emediapark.eos.ws.Shipment"/>
      
       <namespaces target-namespace="http://de.emediapark.ws/eos/shipment"
       type-namespace="http://de.emediapark.ws/eos/shipment/types"/>
      
       <mapping file="jaxrpc-mapping.xml"/>
       <webservices servlet-link="ShipmentEndpoint"/>
       </java-wsdl>
       </configuration>
      


      Sending the following request to the service:
      POST /eos/shipment?wsdl HTTP/1.1
      Host: EOSDBHOST:8080
      Accept-Charset: UTF-8, UTF-16;q=0.8, iso-8859-1;q=0.8
      Accept-Encoding: deflate, gzip
      Content-Type: text/xml; charset=UTF-8
      SOAPAction: ""
      User-Agent: PocketSOAP/1.5.4/PocketHTTP/1.2.7
      Content-Length: 887
      
      <S:Envelope
       xmlns:a="http://de.emediapark.ws/eos/shipment/types"
       xmlns:S="http://schemas.xmlsoap.org/soap/envelope/"
       xmlns:XS="http://www.w3.org/2001/XMLSchema"
       xmlns:XI="http://www.w3.org/2001/XMLSchema-instance"><S:Body><a:storeAdress><city XI:type="XS:string">Hamburg</city><client XI:type="XS:int">4</client><countryId XI:type="XS:int">0</countryId><countrySign XI:type="XS:string">D</countrySign><kind XI:type="XS:int">0</kind><name1 XI:type="XS:string">XY</name1><name2 XI:type="XS:string"></name2><name3 XI:type="XS:string"></name3><number XI:type="XS:int">3123484</number><postalStreetCode XI:type="XS:int">0</postalStreetCode><status XI:type="XS:int">0</status><street XI:type="XS:string">Fuhlsbuettlerstrasse 223</street><type XI:type="XS:int">0</type><valid XI:type="XS:int">0</valid><zip XI:type="XS:string">22307</zip></a:storeAdress></S:Body></S:Envelope>


      I'm getting the following error from the JBossWS service:

      HTTP/1.1 500 Internal Server Error
      Server: Apache-Coyote/1.1
      X-Powered-By: Servlet 2.4; JBoss-4.0.4.GA (build: CVSTag=JBoss_4_0_4_GA date=200605151000)/Tomcat-5.5
      Set-Cookie: JSESSIONID=DD7CF76F0B97BDA29459C7EE2D724F39; Path=/
      Content-Type: text/xml;charset=UTF-8
      Transfer-Encoding: chunked
      Date: Mon, 25 Sep 2006 21:45:04 GMT
      Connection: close
      
      7b
      <env:Envelope xmlns:env='http://schemas.xmlsoap.org/soap/envelope/'><env:Header/><env:Body><env:Fault><faultcode>env:Client
      c
      </faultcode>
      fe
      <faultstring>org.jboss.ws.binding.BindingException: org.jboss.ws.jaxb.UnmarshalException: Failed to parse source: The prefix "XI" for attribute "XI:type" associated with an element type "city" is not bound. @ *unknown*[1,95]
      e
      </faultstring>
      c
      </env:Fault>
      1a
      </env:Body></env:Envelope>
      0
      
      


      Can anyone give me a hint where to go from here to solve this problem.
      TIA, Gerhard