2 Replies Latest reply on Oct 17, 2006 2:11 PM by Robert Mlekus

    Problem using a .NET client with JBOSSWS 1.0.3

    Srinivas Desirazu Newbie

      We have exposed a web service in JBOSS AS 4.0.4 GA using DOC/LITERAL/WRAPPED.

      We have a .NET client that accesses this web service. In JBOSSWS
      1.0-GA this worked fine. We then upgraded to JBOSSWS 1.0.3-GA and now
      the same setup produces error messages:



      Caused by: org.jboss.ws.jaxb.UnmarshalException: Failed to parse source: The prefix "xsi" for attribute "xsi:nil" associated with an element type "userId" is not bound. @ *unknown*[1,579]

      at org.jboss.ws.jaxb.JBossXBUnmarshallerImpl.unmarshal(JBossXBUnmarshallerImpl.java:67)

      at org.jboss.ws.jaxrpc.encoding.JAXBDeserializer.deserialize(JAXBDeserializer.java:92)

      ... 30 more

      Caused by: org.jboss.xb.binding.JBossXBException: Failed to parse source: The prefix "xsi" for attribute "xsi:nil" associated with an element type "userId" is not bound. @ *unknown*[1,579]

      at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJBossXBParser.java:156)

      at org.jboss.xb.binding.UnmarshallerImpl.unmarshal(UnmarshallerImpl.java:126)

      at org.jboss.ws.jaxb.JBossXBUnmarshallerImpl.unmarshal(JBossXBUnmarshallerImpl.java:63)

      ... 31 more

      Caused by: org.xml.sax.SAXException: The prefix "xsi" for attribute "xsi:nil" associated with an element type "userId" is not bound. @ *unknown*[1,579]

      at org.jboss.xb.binding.parser.sax.SaxJBossXBParser$MetaDataErrorHandler.fatalError(SaxJBossXBParser.java:332)

      at org.apache.xerces.util.ErrorHandlerWrapper.fatalError(Unknown Source)

      at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)

      at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)

      at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)

      at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)

      at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)

      at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)




      It looks like the XML Schema Instance namespace is not being provided
      to the deserializer.

      Is this a bug. If so could it be fixed in the next release.


      Thanks.