6 Replies Latest reply on Aug 31, 2007 11:57 AM by Anis Ben Mahmoud

    Problem with publishing a web service

    Anis Ben Mahmoud Newbie

      Hi all,

      I have this message when I try to publish a class as a web service :


      Running JBossWS wstools for [jbossws-test1]
      directory: C:\FitNetManager\workspaces\workspaceFitNet\jbossws-test1
      command: cmd.exe /C C:\FitNetManager\Jboss-4.0.5.GA\bin\wstools.bat -cp bin -config C:\DOCUME~1\Anis\LOCALS~1\Temp\wstools-config55960.xml -dest C:\FitNetManager\workspaces\workspaceFitNet\jbossws-test1\src\java
      ========================================================================="
      .
      WSTools Environment
      .
      JBOSS_HOME: C:\FitNetManager\Jboss-4.0.5.GA\bin\\..
      .
      JAVA: C:\Program Files\Java\jdk1.5.0_05\bin\java
      .
      JAVA_OPTS:
      .
      ========================================================================="
      .
      Exception in thread "main" java.lang.NoClassDefFoundError: javax/jws/soap/SOAPBinding$ParameterStyle
      at org.jboss.ws.tools.helpers.ToolsHelper.handleJavaToWSDLGeneration(ToolsHelper.java:106)
      at org.jboss.ws.tools.WSTools.process(WSTools.java:133)
      at org.jboss.ws.tools.WSTools.generate(WSTools.java:69)
      at org.jboss.ws.tools.WSTools.generate(WSTools.java:119)
      at org.jboss.ws.tools.WSTools.main(WSTools.java:58)


      I don't understand what is the matter. I'm working on Eclipse 3.2 with JBoss 4.0.5GA, JBossWS 1.2.0SP1, jdk 1.5.
      Could someone help me ???

      Thanks