3 Replies Latest reply on Oct 30, 2008 5:53 PM by Tonio Caputo

    JBossXSModel goes into endless loop

    Sylvie Callens Newbie

      Hi,

      I am new to JbossWs & JAX-WS.

      I created my first Webservice, but when I want to deploy it (now using jboss-4.2.2.GA but I have the same error with other versions) JBossXSModel goes into endless loop :-(

      Can anybody help me with this problem?

      1. service:

      package test.ws;
      
      import javax.jws.WebMethod;
      import javax.jws.WebService;
      import javax.jws.soap.SOAPBinding;
      import javax.jws.soap.SOAPBinding.ParameterStyle;
      import javax.jws.soap.SOAPBinding.Style;
      import javax.jws.soap.SOAPBinding.Use;
      
      import test.ws.xhtml.Html;
      import test.ws.xhtml.ObjectFactory;
      
      @WebService(wsdlLocation="WEB-INF/wsdl/MyService.wsdl")
      @SOAPBinding(style=Style.DOCUMENT, use=Use.LITERAL, parameterStyle=ParameterStyle.WRAPPED)
      public class MyService {
      
       @WebMethod
       public Html getHmtl() {
       return new ObjectFactory().createHtml();
       }
      }


      2. wsdl-file

      <definitions name="MyServiceService"
       targetNamespace="http://ws.test/"
       xmlns="http://schemas.xmlsoap.org/wsdl/"
       xmlns:tns="http://ws.test/"
       xmlns:xhtml="http://www.w3.org/1999/xhtml"
       xmlns:xsd="http://www.w3.org/2001/XMLSchema"
       xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/">
       <types>
       <xsd:import namespace="http://www.w3.org/1999/xhtml" schemaLocation="http://www.w3.org/2002/08/xhtml/xhtml1-strict.xsd"/>
       </types>
       <message name="MyService_getHmtl">
       <part name="getHmtl" element="tns:getHmtl"/>
       </message>
       <message name="MyService_getHmtlResponse">
       <part name="getHmtlResponse" element="tns:getHmtlResponse"/>
       </message>
       <portType name="MyService">
       <operation name="getHmtl" parameterOrder="getHmtl">
       <input message="tns:MyService_getHmtl"/>
       <output message="tns:MyService_getHmtlResponse"/>
       </operation>
       </portType>
       <binding name="MyServiceBinding" type="tns:MyService">
       <soap:binding transport="http://schemas.xmlsoap.org/soap/http" style="document"/>
       <operation name="getHmtl">
       <soap:operation soapAction=""/>
       <input>
       <soap:body use="literal"/>
       </input>
       <output>
       <soap:body use="literal"/>
       </output>
       </operation>
       </binding>
       <service name="MyServiceService">
       <port name="MyServicePort" binding="tns:MyServiceBinding">
       <soap:address location="REPLACE_WITH_ACTUAL_URL"/>
       </port>
       </service>
      </definitions>


      3. logfile

      2008-03-12 10:58:38,906 DEBUG [org.jboss.ws.metadata.umdm.UnifiedMetaData] Eagerly initialize the meta data model
      2008-03-12 10:58:38,906 DEBUG [org.jboss.ws.metadata.wsdl.xmlschema.JBossXSModel] Registered as anon type: {http://www.w3.org/1999/xhtml:>p} -> Complex type ...


      After this, JBossXSModel goes into an endless loop...