0 Replies Latest reply on Sep 15, 2009 3:27 PM by Rishikesh Kollipara

    Having problem Deploying web service in jboss-4.2.2.GA AS

    Rishikesh Kollipara Newbie

      I am trying to deployed wsdl( code generated by jbossws-native-3.0.5GA) on jboss AS 4.2.2.GA. I am getting the following error when it tries to load the DDMS 2.0 specific files. Have no problem deploying using axis. If any body have similar issues loading the DDMS 2.0 using the jbossws please point me in the right direction. Thanks

      14:44:03,616 ERROR [JBossXSErrorHandler] JBossWS_metadata.dod.mil_mdr_ns_DDMS_2.0_4300038152969289372.xsd[domain:http://www.w3.org/TR/xml-schema-1]::[key=src-resolve.4.2]::Message=src-resolve.4.2: Error resolving component 'ns3:type'. It was detected that 'ns3:type' is in namespace 'http://www.w3.org/1999/xlink', but components from this namespace are not referenceable from schema document 'file:/
      C:/jboss-4.2.2.GA/server/default/tmp/jbossws/JBossWS_metadata.dod.mil_mdr_ns_DDM
      S_2.0_4300038152969289372.xsd'. If this is the incorrect namespace, perhaps the prefix of 'ns3:type' needs to be changed. If this is the correct namespace, then an appropriate 'import' tag should be added to 'file:/C:/jboss-4.2.2.GA/server/default/tmp/jbossws/JBossWS_metadata.dod.mil_mdr_ns_DDMS_2.0_4300038152969289372
      .xsd'.

      14:44:03,616 ERROR [JBossXSErrorHandler] JBossWS_metadata.dod.mil_mdr_ns_DDMS_2.
      0_4300038152969289372.xsd[domain:http://www.w3.org/TR/xml-schema-1]::[key=s4s-elt-invalid-content.1]::Message=s4s-elt-invalid-content.1: The content of '#AnonType_linkRelatedResourceRelatedResourcesType' is invalid. Element 'attribute' is invalid, misplace, or occurs too often