0 Replies Latest reply on May 27, 2008 5:21 PM by Jason Long

    Datascroller not resetting in 3.2.1 snapshot

    Jason Long Master

      My datascroller no longer resets in 3.2.1. I used this previously and it worked.

      I have the following seam component bound to the datatable as follows:

      <rich:dataGrid value="#{contactExtendedDataModel}" var="contactL" columns="3" id="contactListGrid" elements="6">
       <f:facet name="header">
       <a4j:form id="contactListForm">
       <h:inputText value="#{strCompanyFilter}" />
       <a4j:commandButton image="images/buttons/view_details.gif" action="#{listContactSearch.search}" reRender="contactListGrid,contactListForm" />
       <rich:datascroller id="contactListDatascroller" for="contactListGrid" binding="#{contactDatascrollerUI.datascroller}" />
       </a4j:form>
       </f:facet>
      ....


      @Name("contactDatascrollerUI")
      public class ContactUIDatascroller implements Serializable
      {
      
       private static final long serialVersionUID = 8846343455775648L;
      
       private UIDatascroller datascroller;
       public UIDatascroller getDatascroller() { return datascroller; }
       public void setDatascroller(UIDatascroller datascroller) { this.datascroller = datascroller; }
      
       @Observer("reset.contact.search.datascroller")
       public void resetDatascroller()
       {
       System.out.println("reset.contact.search.datascroller");
       if(datascroller!=null) datascroller.setPage(1);
       }
      }


      resetDatascroller() is called during INVOKE_APPLICATION phase, but I still get a message like the following.

      15:34:13,938 WARN [UIDatascroller] Datascroller contactListGrid:contactListForm:contactListDatascroller: The requested page #2 isn't found in the model containing 1 pages. Paging is reset to page #1


      I have not tested this code since 3.1.4, so I do not know when it stopped working. It wants to use the page that was selected previously. I tried different scopes, but they all react the same.

      Any suggestions?