0 Replies Latest reply on Apr 16, 2008 8:29 AM by Martin Ganserer

    TimerService problem

    Martin Ganserer Newbie

      Hello,

      I am using JBOSS 4.2.2 GA and want to use the TimerService

      Here is my example code:

      
      @Stateless
      @Local(ProductionOrderService.class)
      public class ProductionOrderServiceBean implements ProductionOrderService
      private @Resource TimerService timerService;
      private @EJB FileGenerationService fileGenerationService;
      ...
      
      void doSomething()
      {
      ...
      timerService.createTimer(new Date(System.currentTimeMillis() + FILE_GEN_DELAY_VALUE), prodOrder);
      ...
      }
      
      @Timeout
      @PermitAll
      public void fileGenerationTimeOut(Timer timer)
      {
       ProductionOrderCreateDTO prodOrder = (ProductionOrderCreateDTO) timer.getInfo();
       fileGenerationService.generateProductionOrderFile(prodOrder);
      }


      The timer event is fired after the FILE_GEN_DELAY_VALUE. The problem is that I always get a javax.ejb.EJBAccessException: Authentication failure.
      And YES, I added:

      <module-option name = "unauthenticatedIdentity">Homer Simpson</module-option>


      to application login module!

      BTW: I even tried to add "@PermitAll" to the generateProductionOrderFile method. But this didn't solved the problem either!

      I would appreciate your help!

      Thank you in advance!