1 Reply Latest reply on Sep 24, 2005 7:22 PM by Ronald van Kuijk

    starters kit seems to require jdk 1.5

    Gary Shea Newbie

      Classes in the starter kit are compiled with jdk 1.5, in particular I was getting an error when running 1.4.2_09:

      6:13:52,334 ERROR [MainDeployer] could not create deployment: file:/home/shea/tmp/jbpm-test/jbpm-starters-kit-3.0.1/jbpm-server/server/jbpm/deploy/jbpm.sar/
      org.jboss.deployment.DeploymentException: Unexpected error during load of: org.jbpm.db.jmx.JbpmService, msg=org/jbpm/db/jmx/JbpmService (Unsupported major.minor version 49.0); - nested throwable: (java.lang.ClassNotFoundException: Unexpected error during load of: org.jbpm.db.jmx.JbpmService, msg=org/jbpm/db/jmx/JbpmService (Unsupported major.minor version 49.0))

      After switching to the 1.5 jdk, it started up just fine. We'll see if everything works :)

      Gary