4 Replies Latest reply on Jun 20, 2006 10:08 AM by Jay Hiremath

    Build from CVS Head

    Jay Hiremath Newbie

      I may be jumping the gun here.. but in my attempt to get a version of jBPM working in JBoss AS 4.0.4.GA, I built jBPM from CVS Head and deployed the resulting .sar and the console war. When I run the console and attempt a login I see a missing properties file: defaultUsers.properties.

      2006-06-16 10:25:49,500 ERROR [org.jboss.security.auth.spi.UsersRolesLoginModule] Failed to load users/passwords/role files
      java.io.IOException: No properties file: users.properties or defaults: defaultUsers.properties found

      Does anyone know where I can get this file?

      or Has anyone successfuly deployed 3.1.1 and the corresponding jbpm.war and gotten it to work? I first ran into ehcache version issue and after I upgraded it I got missing table exceptions related to scheduler. I also got some exceptions while launching the console.

        • 1. Re: Build from CVS Head
          David Hosier Novice

          If you look at the Exception there, you can see it's a JBoss thing and not a jBPM thing. I beleive this is part of the security model. I can't tell you why your server would be looking for that file, unless the HEAD version of jBPM has added a hook into the JBoss security mechanism. Try creating the users.properties file in the conf/props directory of your server and see if that clear things up. If the jBPM webapp now hooks into the JBoss security mechanism, you may have to add the users to the properties file. Here is an example of what gets created when you tell the JBoss installer to secure the JMX Console:

          # A sample users.properties file for use with the UsersRolesLoginModule
          admin=admin
          

          I think that's just the username and then the password. I don't know much about this, but I think it's a start to try to get you going.

          • 2. Re: Build from CVS Head
            Jay Hiremath Newbie

            You are right it is a JAAS login module related config... I was just wondering if the console war should have packaged one. I will try to create this file per your suggestion. Thanks.

            • 3. Re: Build from CVS Head
              Jay Hiremath Newbie

              I have gone past the login problem.. however I now see an exception in participantBean

              javax.el.ELException: /participant/home.xhtml @29,86 items="#{participantBean.personalTaskInstances}": org.jbpm.webapp.bean.ParticipantBean.....

              but the underlying cause is:

              ********************** Exception Trace Begin*************
              Caused by: java.sql.SQLException: Table not found in statement [select taskinstan0_.ID_ as ID1_27_, taskinstan0_.NAME_ as NAME3_27_, taskinstan0_.DESCRIPTION_ as DESCRIPT4_27_, taskinstan0_.ACTORID_ as ACTORID5_27_, taskinstan0_.CREATE_ as CREATE6_27_, taskinstan0_.START_ as START7_27_, taskinstan0_.END_ as END8_27_, taskinstan0_.DUEDATE_ as DUEDATE9_27_, taskinstan0_.PRIORITY_ as PRIORITY10_27_, taskinstan0_.ISCANCELLED_ as ISCANCE11_27_, taskinstan0_.ISSUSPENDED_ as ISSUSPE12_27_, taskinstan0_.ISOPEN_ as ISOPEN13_27_, taskinstan0_.ISSIGNALLING_ as ISSIGNA14_27_, taskinstan0_.ISBLOCKING_ as ISBLOCKING15_27_, taskinstan0_.TASK_ as TASK16_27_, taskinstan0_.TOKEN_ as TOKEN17_27_, taskinstan0_.SWIMLANINSTANCE_ as SWIMLAN18_27_, taskinstan0_.TASKMGMTINSTANCE_ as TASKMGM19_27_ from JBPM_TASKINSTANCE taskinstan0_ where taskinstan0_.ACTORID_=? and taskinstan0_.ISOPEN_=1]
              at org.hsqldb.jdbc.Util.throwError(Unknown Source)
              at org.hsqldb.jdbc.jdbcPreparedStatement.(Unknown Source)
              at org.hsqldb.jdbc.jdbcConnection.prepareStatement(Unknown Source)
              at org.jboss.resource.adapter.jdbc.BaseWrapperManagedConnection.doPrepa

              ********************** Exception Trace End *************

              This leads me to believe that the sar deployment and the corresponding db configuration did not go through smoothly. I did not notice any errors in the server.log, however I do not see a whole lot of Hibernate debug log that I usually see when I deploy the 3.1.1 sar.

              I badly need a version of jBPM running in 4.0.4.GA. Any help is much appreciated.

              I also went back to trying jBPM 3.1.1 in 4.0.4.GA and this time I downloaded the 3.1.1 branch source and rebuilt it using the latest jBoss AS jars, Hibernate 3.2, ehcache1.2. I did notice that I had to add couple of methods to JBpmNamingStrategy.java as the abstract base class in hibernate now has some additional methods. Since most methods in this class were returning null, I took a guess and let Eclipse generate default methods returning null:-)

              However, when I deploy the resulting sar, I see
              ********************** Exception Trace Begin *************
              17:21:45,843 INFO [Server] JBoss (MX MicroKernel) [4.0.4.GA (build: CVSTag=JBos
              s_4_0_4_GA date=200605151000)] Started in 17s:343ms
              17:21:46,250 WARN [EhCacheProvider] Could not find configuration [org.jbpm.grap
              h.def.ProcessDefinition]; using defaults.
              17:21:54,015 WARN [EhCacheProvider] Could not find configuration [org.jbpm.grap
              h.def.ExceptionHandler]; using defaults.
              17:21:54,015 WARN [EhCacheProvider] Could not find configuration [org.jbpm.modu
              le.def.ModuleDefinition]; using defaults.
              ......
              .....
              ********************** Exception Trace End *************

              I think this results in another table not found exception :

              ********************** Exception Trace Begin *************
              17:21:55,703 ERROR [JDBCExceptionReporter] Table not found in statement [select
              message0_.ID_ as col_0_0_ from JBPM_MESSAGE message0_ where message0_.DESTINATIO
              N_=? and message0_.ISSUSPENDED_<>1 and (message0_.EXCEPTION_ is null)]
              ********************** Exception Trace End *************

              Sorry for the long post but I would love to know if anyone has successfuly gotten 3.1.1 (or the latest jBPM) to run under jBoss AS 4.0.4.GA. If so a brief description of the steps you took and the results would be appreciated. As a last resort, if mods can indicate as to when there is likely to be a build/release for 4.0.4.GA it would be great to know that.

              Thanks

              PS: When I built jBPM, I went with ehcache1.2 and hibernate 3.2 because there was another thread in this forum that mentioned this.

              • 4. Re: Build from CVS Head
                Jay Hiremath Newbie

                Copying localDB.script from data/hypersonic resolved this issue for all builds: 3.1.1, 3.2 local build, etc.,

                This topic is discussed elsewhere on the forum. Thanks.