2 Replies Latest reply on Dec 22, 2006 1:39 PM by Alejandro Guizar

    probmlem with jbpm bpel with doc/lit

    Anjai Lal Newbie

      sorry guys, some prob with my machine...neways the following is the bpel process:



      <!--
      <?xml version="1.0" encoding="UTF-8"?>
      <process name="review" targetNamespace="urn:author"
      xmlns:urn="urn:author"
      xmlns:rev="urn:reviewer"
      xmlns:bpel="http://schemas.xmlsoap.org/ws/2003/03/business-process/"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://schemas.xmlsoap.org/ws/2003/03/business-process/
      http://schemas.xmlsoap.org/ws/2003/03/business-process/"
      xmlns="http://schemas.xmlsoap.org/ws/2003/03/business-process/">



      <!-- realizes the abstract relationship with the caller -->
      partnerLink name="caller" partnerLinkType="urn:callerPLT" myRole="service"/>

      <!-- realizes the relationship with the reviewer1 -->
      partnerLink name="reviewer1" partnerLinkType="urn:reviewPLT" partnerRole="review"/>

      /partnerLinks>

      variables>
      <!-- holds the incoming message -->
      variable name="request" messageType="rev:reviewRequest"/>
      variable name="request1" messageType="rev:reviewRequest"/>
      <!-- holds the outgoing message -->
      variable name="response" messageType="rev:reviewResponse"/>
      variable name="response1" messageType="rev:reviewResponse"/>
      /variables>

      sequence>
      !-- receive a message carrying the name of a person -->
      receive operation="reviewRequest" partnerLink="caller" portType="urn:callerPT"
      variable="request" createInstance="yes"/>

      assign name="copy1">
      copy>
      from variable="request"/>
      to variable="request1"/>
      /copy>
      /assign>

      invoke operation="review" partnerLink="reviewer1" portType="rev:Reviewer"
      inputVariable="request1" outputVariable="response1">
      /invoke>

      assign name="copy2">
      copy>
      from variable="response1"/>
      to variable="response"/>
      /copy>
      /assign>



      <!-- reply with a message carrying the greeting -->
      reply operation="reviewRequest" partnerLink="caller" portType="urn:callerPT"
      variable="response"/>

      /sequence>

      /process>
      -->


      please disregard the tags...it was not gettin uploaded otherwise..
      the wsdl associated with the ablove bpel process is as follows:

      <?xml version="1.0" encoding="UTF-8"?>
      <definitions targetNamespace="urn:author"
      xmlns:urn="urn:author"
      xmlns:rev="urn:reviewer"
      xmlns="http://schemas.xmlsoap.org/wsdl/"
      xmlns:xsd="http://www.w3.org/2001/XMLSchema"
      xmlns:plt="http://schemas.xmlsoap.org/ws/2003/05/partner-link/"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">


      import namespace="urn:reviewer" location="interface/rev.wsdl" />

      <!-- characterizes the relationship between the process and its caller -->
      plt:partnerLinkType name="callerPLT">
      plt:role name="service">
      plt:portType name="urn:callerPT"/>
      /plt:role>
      /plt:partnerLinkType>

      plt:partnerLinkType name="reviewPLT">
      plt:role name="review">
      plt:portType name="rev:Reviewer"/>
      /plt:role>
      /plt:partnerLinkType>

      <!-- describes the interface presented to callers-->
      portType name="callerPT">
      operation name="reviewRequest">
      input message="rev:reviewRequest"/>
      output message="rev:reviewResponse"/>
      /operation>
      /portType>

      /definitions>

      the rev.wssdl imported above is also given below:

      <?xml version="1.0" encoding="UTF-8"?>

      <wsdl:definitions targetNamespace="urn:reviewer"
      xmlns:apachesoap="http://xml.apache.org/xml-soap"
      xmlns:impl="urn:reviewer"
      xmlns:intf="urn:reviewer"
      xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
      xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
      xmlns:wsdlsoap="http://schemas.xmlsoap.org/wsdl/soap/"
      xmlns:xsd="http://www.w3.org/2001/XMLSchema">

      wsdl:types>
      xsd:schema elementFormDefault="qualified" targetNamespace="urn:reviewer">
      xsd:element name="reviewRequest">
      xsd:complexType>
      xsd:sequence>
      xsd:element name="name" type="xsd:string"/>
      /xsd:sequence>
      /xsd:complexType>
      /xsd:element>
      xsd:element name="reviewResponse">
      xsd:complexType>
      xsd:sequence>
      xsd:element name="value" type="xsd:int"/>
      /xsd:sequence>
      /xsd:complexType>
      /xsd:element>
      /xsd:schema>
      /wsdl:types>

      wsdl:message name="reviewResponse">
      wsdl:part name="output" element="impl:reviewResponse"/>
      /wsdl:message>
      wsdl:message name="reviewRequest">
      wsdl:part name="in0" element="impl:reviewRequest"/>
      /wsdl:message>

      wsdl:portType name="Reviewer">
      wsdl:operation name="reviewRequest" parameterOrder="in0">
      wsdl:input message="impl:reviewRequest" name="reviewRequest"/>
      wsdl:output message="impl:reviewResponse" name="reviewResponse"/>
      /wsdl:operation>
      /wsdl:portType>

      wsdl:binding name="reviewerSoapBinding" type="impl:Reviewer">
      \wsdlsoap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
      wsdl:operation name="reviewRequest">
      \wsdlsoap:operation soapAction=""/>
      wsdl:input name="reviewRequest">
      wsdlsoap:body use="literal"/>
      !--encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="urn:reviewer" -->
      wsdl:input>
      wsdl:output name="reviewResponse">
      wsdlsoap:body use="literal"/>
      /wsdl:output>
      /wsdl:operation>
      /wsdl:binding>

      wsdl:service name="ReviewerService">
      wsdl:port binding="impl:reviewerSoapBinding" name="reviewer">
      wsdlsoap:address location="http://localhost:8080/reviewer/reviewer"/>
      /wsdl:port>
      wsdl:service>
      /wsdl:definitions>


      in the "binding.xml" generated after generate-artifacts, the style has been changed to document/literal. the web-service involved also supports doc/lit format.

      the bpel process gets deployed. using wsdl2Java, the client is generated. i get the following error:

      2006-08-21 12:05:32,093 ERROR [org.jboss.webservice.handler.HandlerChainBaseImpl] RuntimeException in request handler
      java.lang.NullPointerException
      at org.jbpm.bpel.service.provider.PortProvider.getRequestParts(PortProvider.java:363)
      at org.jbpm.bpel.service.provider.PortProvider.sendRequest(PortProvider.java:316)
      at org.jbpm.bpel.service.provider.PortProvider.handleRequest(PortProvider.java:202)
      at org.jboss.webservice.handler.HandlerWrapper.handleRequest(HandlerWrapper.java:106)
      at org.jboss.webservice.handler.HandlerChainBaseImpl.handleRequest(HandlerChainBaseImpl.java:216)
      at org.jboss.webservice.handler.ServerHandlerChain.handleRequest(ServerHandlerChain.java:52)
      at org.jboss.webservice.server.InvokerProviderJSE.invokeTarget(InvokerProviderJSE.java:74)
      at org.jboss.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:121)
      at org.jboss.axis.providers.java.JavaProvider.invoke(JavaProvider.java:358)
      at org.jboss.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:73)
      at org.jboss.axis.SimpleChain.doVisiting(SimpleChain.java:160)
      at org.jboss.axis.SimpleChain.invoke(SimpleChain.java:123)
      at org.jboss.axis.handlers.soap.SOAPService.invoke(SOAPService.java:560)
      at org.jboss.webservice.server.ServerEngine.invokeInternal(ServerEngine.java:200)
      at org.jboss.webservice.server.ServerEngine.invoke(ServerEngine.java:89)
      at org.jboss.axis.transport.http.AxisServlet.doPost(AxisServlet.java:911)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.jboss.axis.transport.http.AxisServletBase.service(AxisServletBase.java:370)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
      at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
      at org.jboss.web.tomcat.security.CustomPrincipalValve.invoke(CustomPrincipalValve.java:39)
      at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:159)
      at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:59)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
      at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
      at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
      at java.lang.Thread.run(Thread.java:595)


      can somebody please help out with this problem??

        • 1. Re: probmlem with jbpm bpel with doc/lit
          Darren Pitt Newbie

          I am having the very same problem, I am running jBoss 4.0.4 GA and I tried installing the BPEL Beta 1, then Beta 2. Had the same problem on both installations. I'm not getting an error on startup of the server which makes me think that it is not related to data source. Since the example processes were installed automatcally using ant with Beta 2 deployment doesn't seem to be an issue with the BPEL or WSDL code.

          My guess is that I'm missing something simple in the server settings, but I'll be damned if I can find out what it is.

          I would be grateful for any suggestions, and would help save the hair that I haven't already pulled out.

          Thanks,

          Darren.

          • 2. Re: probmlem with jbpm bpel with doc/lit
            Alejandro Guizar Master

             

            in the "binding.xml" generated after generate-artifacts, the style has been changed to document/literal


            Publishing doc/lit endpoints is not possible at this time. This task is already in our road map as BPEL-144. The workaround is changing your reviewRequest and reviewResponse to reference complex types instead of elements and leaving the binding style as rpc.

            Note that you *can* consume document endpoints.

            I know this is inconvenient; we are working hard to deal with the issues that you guys find in the product.

            Happy holidays!