4 Replies Latest reply on Dec 10, 2008 6:56 PM by Ronald van Kuijk

    Deploy jBPM bpel on Weblogic

    Abhijeet Newbie

      Hi,

      I am trying to deploy jBPM / BPEL on Weblogic 9.2. I created the ear and it gets deployed in JBoss properly. Please help me with the steps to do so in Weblogic.

      Regards,
      Abhijeet

        • 1. Re: Deploy jBPM bpel on Weblogic
          venkat esh Newbie

          hi abhijeet,

          are you able to deploy jbpm on weblogic,
          if done, can you please share your knowlege on same.

          i trying to deploy jbpm 3.0 on weblogic 10.3

          regards
          venkat

          • 2. Re: Deploy jBPM bpel on Weblogic
            Ronald van Kuijk Master

            WHAT.... 3.0 on WLS 10sp3? hmmmmmmmmmm Something is not right here.

            • 3. Re: Deploy jBPM bpel on Weblogic
              venkat esh Newbie

              Hi Ronald,

              i am trying to deploy ear containing JBPM seam and ejb3 on weblogic 10.3.

              ending up with the below error mentioning java.lang.NoClassDefFoundError: org/jbpm/JbpmContext

              i will be thankfull if you give some inputs to resolve this.

              regards
              venkat


              deploy:
              [wldeploy] weblogic.Deployer -verbose -noexit -name xpr -source D:\build_xpr\dist\xpr.ear -targets AdminServer -adminurl iiop://blrkec44928L:7050 -user weblogic -password ******** -deploy
              [wldeploy] weblogic.Deployer invoked with options: -verbose -noexit -name xpr -source D:\build_xpr\dist\xpr.ear -targets AdminServer -adminurl iiop://blrkec44928L:7050 -user weblogic -deploy
              [wldeploy] <Dec 10, 2008 11:32:30 AM IST> <J2EE Deployment SPI> <BEA-260121> <Initiating deploy operation for application, xpr [archive: D:\build_xpr\dist\xpr.ear], to AdminServer .>
              [wldeploy] Task 1 initiated: [Deployer:149026]deploy application xpr on AdminServer.
              [wldeploy] Task 1 failed: [Deployer:149026]deploy application xpr on AdminServer.
              [wldeploy] Target state: deploy failed on Server AdminServer
              [wldeploy] java.lang.NoClassDefFoundError: org/jbpm/JbpmContext
              [wldeploy]
              [wldeploy]
              [wldeploy] Target Assignments:
              [wldeploy] + xpr AdminServer

              BUILD FAILED
              D:\XPR\build.xml:297: weblogic.Deployer$DeployerException: weblogic.deploy.api.tools.deployer.DeployerException: Task 1 failed: [Deployer:149026]deploy application xpr on AdminServer.
              Target state: deploy failed on Server AdminServer

              • 4. Re: Deploy jBPM bpel on Weblogic
                Ronald van Kuijk Master

                Sorry, I stopped using WLS when they still were at 8.1.6 (8.1sp6) (my previous employer is still at that version, for which I pitty them) and have no urge to start using it again. Never had much deployment/packaging/classloading/.... errors since then...