4 Replies Latest reply on Aug 5, 2008 11:57 PM by Biren Barodia

    Digester Error

    Biren Barodia Newbie

      Hi,
      I am new to Richfaces. I have downloaded the latest RFaces 3.2.1 GA
      I am working on Netbeans 6.0 with jboss 4.2.3.
      I think I am missing some libraries which is why I am getting the Digester error at RFaces/META-INF/faces-config.xml about no grammar found.

      I have the following jars in my WEB-INF/lib directory.

      commons-beanutils-bean-collections.jar
      commons-beanutils-core.jar
      commons-beanutils.jar
      commons-collections-3.2.1.jar
      commons-collections-3.2.1-javadoc.jar
      commons-collections-3.2.1-sources.jar
      commons-collections-testframeworks-3.2.1.jar
      commons-collections.jar
      commons-digester-1.8.jar
      commons-digester.jar
      commons-el-1.0.jar
      commons-logging.jar
      el-api-1.0.jar
      el-impl-1.0.jar
      jcommon-0.9.6.jar
      jsf-facelets.jar
      jsf-impl.jar
      jstl.jar
      jxl.jar
      myfaces-all.jar
      myfaces-impl.jar
      myfaces-api.jar
      richfaces-api-3.2.1.GA.jar
      richfaces-impl-3.2.1.GA.jar
      richfaces-ui-3.2.1.GA.jar


      Can some1 suggest what libraries I am missing ?

        • 1. Re: Digester Error
          Biren Newbie

          bounce

          • 2. Re: Digester Error
            Ilya Shaikovsky Master

            just hell in your classpath..

            1) you have my faces and JSF RI libs both in libs.
            2) JBoss already provides one more myfaces libs in own commons
            3) el-api,el-ri should not be in your libs for Jboss 4.2.3
            4) there are duplicated commons jars (commons-digester-1.8.jar commons-digester.jar)

            Simpliest way - to download working example for your environment and take libs from this example.. and also check the web.xml if there are problems after libs are ok.

            • 3. Re: Digester Error
              Biren Newbie


              1) you have my faces and JSF RI libs both in libs. --- removed jsf-ri and myfaces
              2) JBoss already provides one more myfaces libs in own commons
              3) el-api,el-ri should not be in your libs for Jboss 4.2.3 --- removed
              4) there are duplicated commons jars (commons-digester---1.8.jar commons-digester.jar) --- removed unversioned jar

              still my error is the same...

              14:59:20,794 ERROR [Digester] Parse Error at line 2 column 14: Document is invalid: no grammar found.
              org.xml.sax.SAXParseException: Document is invalid: no grammar found.


              • 4. Re: Digester Error
                Biren Barodia Newbie

                bounce again