1 Reply Latest reply on Aug 27, 2009 1:28 AM by tian su

    BUILD FAILED and  deployment failed: Internal server  Error

    mamidala reddy Newbie

      When I Build BPEL process hello example , I am geting below error

      xe8][0x6][0xc6][0xa7][0xf9]v[0x8e][0x7][0xe0][0xc4][0xe9]@5[0x1c]t[0xce]:[0xc9][
      0xfd]D[0xa8][0x1c]{[0xb3][0x8e][0xf8]*[0xdd]^W[0x8][0x11][0xc3]^[0x97][0x9d]a[0x
      97]p[0x99][0xf2][0xdd]0[0x9a]j[0x1d][0x81]?m}[0x84][0x96][0x1f][0x89]FS[0xc2][0x
      89]l[0x1][0x92][0xee][0xc1][0xb9][0xfc][0x87][0xf5][0x94][0xf1]RN[0xde]7[0xeb][0
      xbf]PK[0x1][0x2][0x14][0x3][\n]"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "[0x0][0x0][0x0][0x8][0x0][0xf]j
      }7[0x6][0xdc][0x13][0xc5]?[0x2][0x0][0x0][0x9b][0x5][0x0][0x0][\n]"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "[0x0][0x0][0x0][0x0][0x0][0x0][
      0x0][0x0][0x0][0x0][0x0][0xa4][0x81][0x0][0x0][0x0][0x0]hello.bpelPK[0x1][0x2][0
      x14][0x3][\n]"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "[0x0][0x0][0x0][0x8][0x0][0xf]j
      }7[0xb7][0xc6][0xa1]y[0xee][0x1][0x0][0x0][0xa5][0x4][0x0][0x0][\n]"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "[0x0][0x0][0x0][0x0][0x0][0x0][
      0x0][0x0][0x0][0x0][0x0][0xa4][0x81]g[0x2][0x0][0x0]hello.wsdlPK[0x5][0x6][0x0][
      0x0][0x0][0x0][0x2][0x0][0x2][0x0]p[0x0][0x0][0x0]}[0x4][0x0][0x0][0x0][0x0]"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "[\r][\n]"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "--"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "X6J-lx4RlPCjJ6ZxyI8tzOFSGn9aN5V
      r8t"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "--"
      [deployprocess] 11:35:16,678 DEBUG [content] >> "[\r][\n]"
      [deployprocess] 11:35:17,961 DEBUG [header] << "HTTP/1.1 500 Internal Server Err
      or[\r][\n]"
      [deployprocess] 11:35:17,961 DEBUG [header] << "Server: Apache-Coyote/1.1[\r][\n
      ]"
      [deployprocess] 11:35:17,961 DEBUG [header] << "Content-Type: text/html;charset=
      utf-8[\r][\n]"
      [deployprocess] 11:35:17,961 DEBUG [header] << "Content-Length: 2154[\r][\n]"
      [deployprocess] 11:35:17,961 DEBUG [header] << "Date: Tue, 07 Apr 2009 06:05:17
      GMT[\r][\n]"
      [deployprocess] 11:35:17,961 DEBUG [header] << "Connection: close[\r][\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "JBossWeb/2.0
      .0.GA - Error report<!--H1 {font-family:Tahoma,Arial,sans-serif;c
      olor:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Aria
      l,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-fami
      ly:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;}
      BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;}
      B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P
      {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px
      ;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--> </he
      ad><h1>HTTP Status 500 - </h1>type Exception reportmessage description The
      server encountered an internal error () that prevented it from fulfilling this r
      equest.exception java.lang.NullPointerException[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.tools.Wscomp
      ileTool.getLocation(WscompileTool.java:240)[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.tools.Wscomp
      ileTool.formatClasspath(WscompileTool.java:227)[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.tools.Wscomp
      ileTool.callWscompile(WscompileTool.java:197)[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.tools.Wscomp
      ileTool.generateJavaMappingImpl(WscompileTool.java:156)[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.tools.Wscomp
      ileTool.generateJavaMapping(WscompileTool.java:143)[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.tools.WebMod
      uleBuilder.callJavaMappingTool(WebModuleBuilder.java:264)[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.tools.WebMod
      uleBuilder.buildModuleImpl(WebModuleBuilder.java:102)[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.tools.WebMod
      uleBuilder.buildModule(WebModuleBuilder.java:84)[\n]"
      [deployprocess] 11:35:17,976 DEBUG [content] << "[0x9]org.jbpm.bpel.web.Deployme
      ntServlet.deployWebModule(DeploymentServlet.java:205)[\n]"
      [deployprocess] 11:35:17,992 DEBUG [content] << "[0x9]org.jbpm.bpel.web.Deployme
      ntServlet.doPost(DeploymentServlet.java:99)[\n]"
      [deployprocess] 11:35:17,992 DEBUG [content] << "[0x9]javax.servlet.http.HttpSer
      vlet.service(HttpServlet.java:710)[\n]"
      [deployprocess] 11:35:17,992 DEBUG [content] << "[0x9]javax.servlet.http.HttpSer
      vlet.service(HttpServlet.java:803)[\n]"
      [deployprocess] 11:35:17,992 DEBUG [content] << "[0x9]org.jboss.web.tomcat.filte
      rs.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)[\n]"
      [deployprocess] 11:35:17,992 DEBUG [content] << "note The
      full stack trace of the root cause is available in the JBossWeb/2.0.0.GA logs.<
      /u><h3>JBossWeb/2.0.0.GA</h3>"

      BUILD FAILED
      E:\jbpm-bpel-1.1.GA\examples\common\bpel-build.xml:61: deployment failed: Intern
      al Server Error