2 Replies Latest reply on Dec 28, 2005 10:49 PM by Pedro Lira

    CMS Service Failed

    Pedro Lira Newbie

      I installed JBoss portal 2.2 from the binary release, using MySql 4.1.15 as database and JBoss AS 4.0.3 SP1. Whe the AS startsup I get the following message :

      --- MBeans waiting for other MBeans ---
      ObjectName: portal:service=CMS
      State: FAILED
      Reason: org.apache.jackrabbit.core.config.ConfigurationException: File system initialization failure.: failed to in
      itialize file system: null: failed to initialize file system: null
      I Depend On:
      jboss.jca:service=DataSourceBinding,name=PortalDS
      portal:service=JAASLoginModule
      Depends On Me:
      portal:mapper=CMSObject

      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: portal:service=CMS
      State: FAILED
      Reason: org.apache.jackrabbit.core.config.ConfigurationException: File system initialization failure.: failed to in
      itialize file system: null: failed to initialize file system: null
      I Depend On:
      jboss.jca:service=DataSourceBinding,name=PortalDS
      portal:service=JAASLoginModule
      Depends On Me:
      portal:mapper=CMSObject


      When looking back on the startup log I found:

      23:17:04,137 ERROR [HibernateStore] failed to initialize file system
      java.lang.NullPointerException
      at java.util.Hashtable.put(Hashtable.java:396)
      at java.util.Properties.setProperty(Properties.java:128)
      at org.hibernate.cfg.Configuration.setProperty(Configuration.java:1201)
      at org.jboss.portal.cms.hibernate.HibernateStore.init(HibernateStore.java:209)
      at org.apache.jackrabbit.core.config.FileSystemConfig.init(FileSystemConfig.java:55)
      at org.apache.jackrabbit.core.config.RepositoryConfig.init(RepositoryConfig.java:230)
      at org.apache.jackrabbit.core.config.RepositoryConfig.create(RepositoryConfig.java:128)
      at org.apache.jackrabbit.core.config.RepositoryConfig.create(RepositoryConfig.java:70)
      at org.apache.jackrabbit.core.jndi.BindableRepository.init(BindableRepository.java:122)
      at org.apache.jackrabbit.core.jndi.BindableRepository.create(BindableRepository.java:110)
      at org.apache.jackrabbit.core.jndi.RegistryHelper.registerRepository(RegistryHelper.java:57)
      at org.jboss.portal.cms.util.RepositoryUtil.registerRepository(RepositoryUtil.java:69)
      at org.jboss.portal.cms.impl.jcr.JCRCMS.startService(JCRCMS.java:222)
      at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:274)

      the log continue, but it does not make sence to post all of it.

      The portal works, but the CMS functinality is not available, for obvious reason, it did not started up.

      Any help or additional questions are wellcome.

      Pedro Lira