1 2 Previous Next 15 Replies Latest reply on May 22, 2006 2:54 PM by Edgardo Luzcando

    No layout found for layout id generic

    Ted Letts Newbie

      JBoss 4.0.3.SP1
      JBoss Portal 2.2.1RC3
      MySQL 4.1.12
      MySQL JDBC Connector 3.1.12
      Java 1.5.0_06-b05
      RedHat ES 4 - 2.6.9-34

      I am receiving the following error when accessing the localhost:8080/portal site...

      javax.servlet.ServletException: No layout found for layout id generic
       org.jboss.portal.server.servlet.PortalServlet.doGet(PortalServlet.java:227)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:697)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
       org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)
      


      The connection to the database appears to be working correctly - as the intitial run created and populated the portal tables (33 tables created).

      I receive the following error messages at the tail of the AS startup...
      10:06:33,105 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
      
      --- MBeans waiting for other MBeans ---
      ObjectName: portal:policy=PortalPolicyConfigStore,type=Component
       State: FAILED
       Reason: java.lang.IllegalArgumentException: No transaction manager provided
       I Depend On:
       portal:policy=JaccPortalPolicyConfigurator
       portal:service=TreeCacheProvider,type=transient
       portal:policy=PortalPolicyConfigService
       Depends On Me:
       portal:deploymentFactory=PortletApp
      
      ObjectName: portal:deploymentFactory=PortletApp
       State: CONFIGURED
       I Depend On:
       portal:deployer=PortalWebApp
       portal:service=WebAppRegistry
       portal:service=ServerConfig
       portal:policy=PortalPolicyConfigStore,type=Component
       Depends On Me:
       portal:deployer=Adapter
      
      ObjectName: portal:deployer=Adapter
       State: CONFIGURED
       I Depend On:
       portal:deploymentFactory=Object
       portal:deploymentFactory=PortletApp
       portal:deploymentFactory=Layout
       portal:deploymentFactory=LayoutFeatures
       portal:deploymentFactory=Theme
       portal:service=Module,type=User
       portal:service=Module,type=Role
       portal:service=Module,type=Mail
       portal:deployer=PortalWebApp
       jboss.web:service=WebServer
      
      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: portal:policy=PortalPolicyConfigStore,type=Component
       State: FAILED
       Reason: java.lang.IllegalArgumentException: No transaction manager provided
       I Depend On:
       portal:policy=JaccPortalPolicyConfigurator
       portal:service=TreeCacheProvider,type=transient
       portal:policy=PortalPolicyConfigService
       Depends On Me:
       portal:deploymentFactory=PortletApp
      
      
      10:06:33,209 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8080
      10:06:33,560 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
      10:06:33,597 INFO [JkMain] Jk running ID=0 time=0/232 config=null
      10:06:33,628 INFO [Server] JBoss (MX MicroKernel) [4.0.3SP1 (build: CVSTag=JBoss_4_0_3_SP1 date=200510231751)] Started in 1m:42s:907ms
      


      Any help would be GREATLY appreciated....


        • 1. Re: No layout found for layout id generic
          Ryszard Kozmik Master

          Hi

          Try the version of JBoss Portal which has JBoss AS bundled. I had the same problem couple days ago and this helped.

          Cheers
          ------------------------
          Ryszard Kozmik
          JBoss Forums Lead

          • 2. Re: No layout found for layout id generic
            Ted Letts Newbie

            Well, had my hopes up. Just tried the above - with different errors...

            using combination package (binary)...
            jboss-portal-2.0.1-jboss-4.0.3SP1

            This time 6 tables were successfully created in MySQL.

            tail of AS startup...

            11:01:23,792 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
            
            --- MBeans waiting for other MBeans ---
            ObjectName: portal:service=CMS
             State: CONFIGURED
             I Depend On:
             jboss.cache:service=InvalidationManager
             jboss.jca:service=DataSourceBinding,name=NoTxPortalDS
             Depends On Me:
             portal:service=Tree
            
            ObjectName: portal:service=Tree
             State: CONFIGURED
             I Depend On:
             portal:service=CMS
             Depends On Me:
             portal:service=Module,type=Security
            
            ObjectName: portal:service=Module,type=Security
             State: CONFIGURED
             I Depend On:
             portal:service=Hibernate
             portal:service=Tree
            
            --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
            ObjectName: jboss.jca:service=DataSourceBinding,name=NoTxPortalDS
             State: NOTYETINSTALLED
             Depends On Me:
             portal:service=CMS
            
            
            11:01:23,940 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8080
            11:01:24,144 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
            11:01:24,184 INFO [JkMain] Jk running ID=0 time=0/63 config=null
            11:01:24,335 INFO [Server] JBoss (MX MicroKernel) [4.0.3SP1 (build: CVSTag=JBoss_4_0_3_SP1 date=200510231054)] Started in 1m:6s:527ms
            


            Now getting error when running portal url...
            javax.servlet.ServletException: An error occured during the action request : Not yet initialized
             org.jboss.portal.core.servlet.CoreServlet.render(CoreServlet.java:174)
             org.jboss.portal.server.servlet.AbstractMainServlet.invoke(AbstractMainServlet.java:81)
             org.jboss.portal.server.servlet.AbstractMainServlet.doGet(AbstractMainServlet.java:71)
             javax.servlet.http.HttpServlet.service(HttpServlet.java:697)
             javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
             org.jboss.portal.core.servlet.TransactionFilter.doFilter(TransactionFilter.java:79)
             org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)


            ... any other thoughts?



            • 3. Re: No layout found for layout id generic
              Roy Russo Master

               

              "tletts" wrote:
              Well, had my hopes up. Just tried the above - with different errors...

              using combination package (binary)...
              jboss-portal-2.0.1-jboss-4.0.3SP1


              Are you using 2.2.1RC3 or 2.0.1? You cite different versions in both posts.

              • 4. Re: No layout found for layout id generic
                Ted Letts Newbie

                Sorry for the confusion.

                The first post specs apply to the first post.

                After the recommendation to try the package (download) that included both AS and Portal, I tried that and got the error messages in my second post.

                So, in common between the posts are the Java, MySQL, Connector, and OS. Both the AS and Portal versions changed between the two. The versions and associated error messages are correct within the posts.

                Clear as mud? :-)

                Thanks again for any thoughts...

                Ted

                • 5. Re: No layout found for layout id generic
                  Ted Letts Newbie

                  FYI -

                  I have also tried Portal 2.2.0 with the standalone AS 4.0.3SP1 (yes, a third configuration) with the same results as the first post.

                  At least I am consistently incompetent...

                  • 6. Re: No layout found for layout id generic
                    Roy Russo Master

                    ok. A few pointers:

                    Unfortunately that stack trace doesn't say much, and we are working on addressing it. Although it points to a problem with the layouts, the problem may not be there at all and simply bubbles up to that point.

                    Mysql4,
                    - download 2.2.1RC2 binary.
                    - drop all existing tables in your db.
                    - make sure you have a recent ga driver for mysql
                    - deploy in /default.
                    - DO NOT use 4.0.3SP1 Installer! You have to use the zip distro.

                    If that doesn't work, i need to finish up some items here, and will look at RC3 w/ mysql4 soon after.

                    • 7. Re: No layout found for layout id generic -> SUCCESS
                      Ted Letts Newbie

                      Success!

                      This is the configuration that worked the magic...
                      JBoss AS 4.0.3SP1
                      -> binary (Installer version did not work)
                      -> standalone (not the combined AS/Portal version)
                      JBoss Portal 2.2.1RC2
                      -> binary
                      -> 2.2.1RC3 / 2.2.0 did not work
                      Java 2 RE 1.5.0_06-b05
                      MySQL Connector/J 3.1.12
                      MySQL 4.1.12

                      Deployed in /default
                      -> the case for all the configs I tried

                      Thanks for the help folks. I am sure I will be back with more questions.

                      Ted

                      • 8. Re: No layout found for layout id generic
                        Nuno Aguiar Newbie

                        First, thank you very much, Roy and tletts. Your messages exchange has greatly helped me. I have just saw the portal server homepage on my screen!!!! :-)

                        Roy, maybe you are interested on my experience as well, since it may give you further hints to resolve the problem. That's why i am replying to this post.

                        I have experienced more or less the same problems as tletts had.

                        One further note: the "effect" of the problem is indeed a servlet exception (with the message "No layout found for generic id") arising when you try to see the portal homepage. But I guess the real problem is more related to an error message that appears on the console, when the application server is starting: something like "IllegalArgumentException: No transaction manager....". I am sorry that I didn't copy pasted it. :-( Roy, I can try to reproduce the exact problem if you want me too.

                        MY PROBLEMATIC COMBINATION
                        - MySQL 5.0.19-nt via TCP/IP
                        - mysql-connector-java-5.0.0-beta-bin.jar
                        - windows XP, version 2002, service pack 2
                        - JVM 1.5.0_06-b05
                        - jboss-4.0.3SP1-installer.jar
                        - jboss-portal-2.2.1RC3.zip

                        MY SUCCESSFULL COMBINATION
                        - MySQL 4.1.12a-nt via TCP/IP
                        - mysql-connector-java-3.1.12-bin.jar
                        - windows XP, version 2002, service pack 2
                        - JVM 1.5.0_06-b05
                        - jboss-4.0.3SP1.zip
                        - jboss-portal-2.2.1RC2.zip

                        I doubt that the problem was on the database because every table was created. But since I was already very anxious to put this to work i just didn't want to take the risk and I just followed your exact instructions.

                        Please LET ME KNOW if you need my help to reproduce the problem. I will surely try!

                        Nuno

                        • 9. Re: No layout found for layout id generic
                          David Spitzer Newbie

                          I just had the same problem with 4.0.4RC2 and found a fix:

                          Open the xml-file 'JBOSS_HOME/server/default/deploy/jboss-portal.sar/META-INF/jboss-service.xml' in an editor.

                          Search for ...

                          name="portal:service=TreeCache,type=transient"


                          ... and add the line ...
                          <depends>jboss:service=TransactionManager</depends>

                          ... to the contents of the TreeCache mbean.

                          • 10. Re: No layout found for layout id generic
                            kiran shashi Newbie

                            This solution also works for SQL Server 2000 datasource

                            also make sure to make use of the jTDS from http://www.freetds.org/

                            • 11. Re: No layout found for layout id generic
                              Ryan Fischer Newbie

                              That fix worked for me using JBoss 4.04RC1. I am curious as to why that needed to be there for the later versions of jboss

                              • 12. Re: No layout found for layout id generic
                                Jonathan Mack Newbie

                                I've also found this works. How did you figure this out???

                                • 13. Re: No layout found for layout id generic
                                  Jose Fernandes Newbie

                                  I just tried the suggested by DViper01 after having the same initial problem in this thread:

                                  My config is:
                                  - jboss-4.0.4.CR2
                                  - WinXP Pro Service Pack 2
                                  - java 1.5.0_06-b05
                                  - MySQL 5.0.21-community
                                  - mysql-connector-java-3.1.12-bin.jar
                                  And with the corrections suggested in:
                                  http://wiki.jboss.org/wiki/Wiki.jsp?page=AvoidMySQL5DataTruncationErrors

                                  Seems like all works!
                                  Thanks for these posts!

                                  • 14. Re: No layout found for layout id generic
                                    Edgardo Luzcando Newbie

                                    My configuration on a Sun v210 with Solaris 8...

                                    * jboss-4.0.3SP1.zip
                                    * mysql-standard-5.0.20-solaris8-sparc.tar.gz
                                    * mysql-connector-java-3.1.12-bin.jar
                                    * jboss-portal-2.2.1.zip
                                    * jdk-1_5_0_06-solaris-sparc(2).sh

                                    I got the AS and Portal to come with in the URL with /web-console/ and /portal/, but I see some errors and warnings that I did not expect. I have yet to try with a 4.x version of MySQL, but I thought I woud try 5.x by disabling the strict mode with SET @@global.sql_mode='';

                                    First error:
                                    18:30:37,196 INFO [FacesConfigurator] Reading config /WEB-INF/faces-config.xml
                                    18:30:37,711 ERROR [LocaleUtils] Locale name null or empty, ignoring
                                    18:30:39,577 INFO [StartupServletContextListener] ServletContext '/usr/local/jboss-4.0.3SP1/server/default/./deploy/jboss-portal.sar/portal-c
                                    ore.war/' initialized.


                                    Second error(s):
                                    18:31:49,071 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:49,071 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_SECURITY_POLICY' doesn't exist
                                    18:31:49,096 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:49,096 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_SECURITY_CONSTRAINT' doesn't exist
                                    18:31:49,123 INFO [Dialect] Using dialect: org.hibernate.dialect.MySQLDialect

                                    First warning(s):
                                    18:31:49,449 INFO [SessionFactoryImpl] building session factory
                                    18:31:49,488 WARN [Configurator] No configuration found. Configuring ehcache from ehcache-failsafe.xml found in the classpath: jar:file:/usr/
                                    local/jboss-4.0.3SP1/server/default/tmp/deploy/tmp55670ehcache.jar!/ehcache-failsafe.xml
                                    18:31:49,529 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.role.RoleImpl]; using defaults.
                                    18:31:49,734 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.PreferenceImpl]; using defaults.
                                    18:31:49,850 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.UserImpl]; using defaults.
                                    18:31:49,955 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.PreferencesImpl]; using defaults.
                                    18:31:50,014 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.PreferencesGroupImpl]; using defaults.
                                    18:31:50,052 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.UserImpl.dynamic]; using defaults.
                                    18:31:50,063 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.role.RoleImpl.users]; using defaults.
                                    18:31:50,066 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.PreferencesImpl.content]; using defaults.
                                    18:31:50,069 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.PreferenceImpl.strings]; using defaults.
                                    18:31:50,071 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.PreferencesGroupImpl.prefMap]; using defaul
                                    ts.
                                    18:31:50,074 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.user.UserImpl.roles]; using defaults.
                                    18:31:50,109 INFO [SessionFactoryObjectFactory] Not binding factory to JNDI, no JNDI name configured
                                    18:31:50,109 INFO [NamingHelper] JNDI InitialContext properties:{}
                                    18:31:50,115 INFO [UpdateTimestampsCache] starting update timestamps cache at region: org.hibernate.cache.UpdateTimestampsCache
                                    18:31:50,124 WARN [EhCacheProvider] Could not find configuration [org.hibernate.cache.UpdateTimestampsCache]; using defaults.
                                    18:31:50,133 INFO [StandardQueryCache] starting query cache at region: org.hibernate.cache.StandardQueryCache
                                    18:31:50,133 WARN [EhCacheProvider] Could not find configuration [org.hibernate.cache.StandardQueryCache]; using defaults.
                                    18:31:50,135 INFO [SessionFactoryImpl] Checking 0 named queries


                                    There are other JDBC-like errors that seem related:
                                    18:31:50,183 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:50,184 ERROR [JDBCExceptionReporter] Table 'jbossportal.jbp_users' doesn't exist
                                    18:31:50,218 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:50,218 ERROR [JDBCExceptionReporter] Table 'jbossportal.jbp_user_pref' doesn't exist
                                    18:31:50,232 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:50,232 ERROR [JDBCExceptionReporter] Table 'jbossportal.jbp_roles' doesn't exist
                                    18:31:50,246 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:50,246 ERROR [JDBCExceptionReporter] Table 'jbossportal.jbp_user_pref_set' doesn't exist
                                    18:31:50,263 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:50,263 ERROR [JDBCExceptionReporter] Table 'jbossportal.jbp_user_prefs_group' doesn't exist
                                    18:31:50,264 INFO [Dialect] Using dialect: org.hibernate.dialect.MySQLDialect
                                    18:31:50,266 INFO [Configuration] processing extends queue

                                    More warnings:
                                    18:31:50,991 INFO [SessionFactoryImpl] building session factory
                                    18:31:50,994 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.instance.InstanceImpl]; using defaults.
                                    18:31:51,076 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.instance.PreferenceImpl]; using defaults.
                                    18:31:51,120 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.instance.InstanceImpl.preferencesMap]; usi
                                    ng defaults.
                                    18:31:51,122 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.instance.PreferenceImpl.strings]; using de
                                    faults.
                                    18:31:51,133 INFO [SessionFactoryObjectFactory] Not binding factory to JNDI, no JNDI name configured

                                    More JDBC-like errors:
                                    18:31:51,141 INFO [SessionFactoryImpl] Checking 0 named queries
                                    18:31:51,164 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:51,165 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_INSTANCE' doesn't exist
                                    18:31:51,182 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:51,182 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_INSTANCE_PREF' doesn't exist
                                    18:31:51,184 INFO [Dialect] Using dialect: org.hibernate.dialect.MySQLDialect

                                    More warnings:
                                    18:31:51,364 INFO [SessionFactoryImpl] building session factory
                                    18:31:51,367 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.portal.PortalObjectImpl]; using defaults.
                                    18:31:51,650 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.portal.ObjectNode]; using defaults.
                                    18:31:51,830 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.portal.PortalImpl.windowStates]; using def
                                    aults.
                                    18:31:51,840 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.portal.PortalObjectImpl.declaredProperties
                                    ]; using defaults.
                                    18:31:51,842 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.portal.ObjectNode.children]; using default
                                    s.
                                    18:31:51,845 WARN [EhCacheProvider] Could not find configuration [org.jboss.portal.core.impl.model.portal.PortalImpl.modes]; using defaults.
                                    18:31:51,936 INFO [SessionFactoryObjectFactory] Not binding factory to JNDI, no JNDI name configured

                                    More JDBC-like errors:
                                    18:31:51,938 INFO [SessionFactoryImpl] Checking 0 named queries
                                    18:31:52,007 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:52,007 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_PORTAL_OBJECT' doesn't exist
                                    18:31:52,020 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:52,020 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_CONTEXT' doesn't exist
                                    18:31:52,092 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:52,093 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_PORTAL' doesn't exist
                                    18:31:52,107 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:52,107 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_PAGE' doesn't exist
                                    18:31:52,121 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:52,121 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_OBJECT_NODE' doesn't exist
                                    18:31:52,134 WARN [JDBCExceptionReporter] SQL Error: 1146, SQLState: 42S02
                                    18:31:52,134 ERROR [JDBCExceptionReporter] Table 'jbossportal.JBP_WINDOW' doesn't exist
                                    18:31:52,136 INFO [Dialect] Using dialect: org.hibernate.dialect.MySQLDialect

                                    The last startup error:
                                    18:32:08,186 INFO [FacesConfigurator] Reading config /WEB-INF/faces-config.xml
                                    18:32:08,260 ERROR [LocaleUtils] Locale name null or empty, ignoring
                                    18:32:08,266 INFO [RenderKitFactoryImpl] RenderKit with renderKitId 'HTML_BASIC' was replaced.
                                    1

                                    At run-time, if I click on Portal Samples I get this:
                                    18:32:09,381 INFO [Server] JBoss (MX MicroKernel) [4.0.3SP1 (build: CVSTag=JBoss_4_0_3_SP1 date=200510231054)] Started in 2m:5s:168ms
                                    18:34:56,476 ERROR [[jsp]] Servlet.service() for servlet jsp threw exception
                                    java.lang.NullPointerException
                                    at org.jboss.console.plugins.helpers.servlet.ServletHelper.filter(ServletHelper.java:29)
                                    at org.apache.jsp.WebModule_jsp._jspService(org.apache.jsp.WebModule_jsp:157)
                                    at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
                                    at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
                                    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:322)
                                    at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
                                    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
                                    at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
                                    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
                                    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
                                    at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)
                                    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
                                    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
                                    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
                                    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
                                    at org.jboss.web.tomcat.security.CustomPrincipalValve.invoke(CustomPrincipalValve.java:39)
                                    at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:159)
                                    at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:59)
                                    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
                                    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
                                    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
                                    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
                                    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
                                    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
                                    at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
                                    at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
                                    at java.lang.Thread.run(Thread.java:595)

                                    For the out of box I did not expect these many, but there might something else nagging at me here. I am going to try with MySQL 4x, but if anyone has any feedback for me I'll be happy to hear it. Cheers!

                                    1 2 Previous Next