1 Reply Latest reply on Nov 6, 2007 10:13 AM by Sohil Shah

    org.jboss.cache.lock.TimeoutException: failure acquiring loc

    Venkata Apparao Newbie

      Hi,

      We are using Jboss-4.0.5GA Server installed on widows platform. We made a two node cluster and deployed jboss-portal2.6.1-ha.sar on the Jboss AS to use the jboss portal framework features.

      After start of the server on access of one of the portal page we get the following error.

      org.hibernate.cache.CacheException: org.jboss.cache.lock.TimeoutException: failure acquiring lock: fqn=/org/hibernate/cache/StandardQueryCache/sql: select userinstan0_.PK as PK26_, userinstan0_.INSTANCE_PK as INSTANCE2_26_, userinstan0_.SER_STATE as SER3_26_, userinstan0_.USER_ID as USER4_26_, userinstan0_.PORTLET_REF as PORTLET5_26_ from JBP_INSTANCE_PER_USER userinstan0_ where userinstan0_.INSTANCE_PK=? and userinstan0_.USER_ID=?; parameters: ; named parameters: {userId=, instanceKey=24}, caller=GlobalTransaction::728, lock=write owner=GlobalTransaction::727 (activeReaders=0, activeWriter=Thread[TP-Processor11,5,jboss], waitingReaders=0, waitingWriters=0, waitingUpgrader=0)
      at org.hibernate.cache.TreeCache.read(TreeCache.java:57)
      at org.hibernate.cache.TreeCache.get(TreeCache.java:45)
      at org.hibernate.cache.StandardQueryCache.get(StandardQueryCache.java:105)
      at org.hibernate.loader.Loader.getResultFromQueryCache(Loader.java:2085)
      at org.hibernate.loader.Loader.listUsingQueryCache(Loader.java:2050)
      at org.hibernate.loader.Loader.list(Loader.java:2020)
      at org.hibernate.loader.hql.QueryLoader.list(QueryLoader.java:393)
      at org.hibernate.hql.ast.QueryTranslatorImpl.list(QueryTranslatorImpl.java:338)
      at org.hibernate.engine.query.HQLQueryPlan.performList(HQLQueryPlan.java:172)
      at org.hibernate.impl.SessionImpl.list(SessionImpl.java:1121)
      at org.hibernate.impl.QueryImpl.list(QueryImpl.java:79)


      This looks like a problem with the hibernate and jboss cache usage in jboss portal.

      Does anybody know if this is a known issue and is there any solution to resolve this, Please respond.

      I have no idea on this cache cofiguration. Please help me to resolve this issue

      Regards
      P V Apparao