4 Replies Latest reply on Jan 31, 2008 2:00 AM by Sohil Shah

    Half working SSO with Portal 2.6.2

    Arne Luedtke Newbie

      Hy there,

      I'm currently trying to develop an SSO System. I want to use a CAS Server for SSO. So I upgraded my Portal 2.6.1 to 2.6.2 because 2.6.2 comes with CAS out of the box. I am running on JBoss AS 4.2.1.

      I set up the CAS Authentication like described in Chapter 19 in den Portal 2.6.2 reference Manual. Everything fine so far.

      When I login to the Portal, I am redirected to the CAS loginpage, where I can use my Portal Account.

      So why do I post this, when everything seams fine? Here are the Problems.

      1. I got the logout Problem, already described here in the forum somewhere. When I press logout, I got logged out, but my ticket isn't invalidatet (so I can login immediately without typing in my uname / password). Is there already a solution found?

      2. When I logged in, and I open a second Browser Window and want to log into a second instance of the Portal, I have to type in my Username / Password again. Not realy SSO ;-). Or is it normal, that I have to log in for each Browser Window?

      Greetings from the snow covered South of Germany
      Arne Luedtke

        • 1. Re: Half working SSO with Portal 2.6.2
          Arne Luedtke Newbie

          Hy,

          Is something wrong with my Question, or is there no answer.

          If there is any extra Information needed, don't hesitate to ask.

          Thanks so far,

          Greetings
          Arne Luedtke

          • 2. Re: Half working SSO with Portal 2.6.2
            Sohil Shah Master

            You are correct. This looks like the CAS integration needs to be fixed.

            We will try to roll this out in subsequent portal release.

            Thanks for the feedback

            • 3. Re: Half working SSO with Portal 2.6.2
              Arne Luedtke Newbie

              Thanks for the answer.

              I'm looking forward to that release.

              Greetings

              Arne Luedtke

              • 4. Re: Half working SSO with Portal 2.6.2
                Sohil Shah Master

                Soon5-

                I am in the process of fixing the second browser window issue and am not being able to reproduce this. Its working fine for me in firefox


                2. When I logged in, and I open a second Browser Window and want to log into a second instance of the Portal, I have to type in my Username / Password again. Not realy SSO ;-). Or is it normal, that I have to log in for each Browser Window?


                Just to be clear, you open a second browser window (I am assuming the same type of browser like Firefox opening another window of FireFox and not IE), and connect to a *different* instance of the Portal other than the one in the first window?

                Are you sure the second instance is also integrated properly with the CAS valve as mentioned in the reference guide?

                to be clear, on the second instance you only need the CAS Valve integration with Portal. You don't need to setup a CAS server on this. There should be only one CAS server shared among all the applications among which SSO needs to be performed

                Thanks