4 Replies Latest reply on Nov 3, 2008 7:38 PM by Travers Naran

    htmlCommandLink and IE6--IE6 keeps messing it up

    Travers Naran Newbie

      I have a table listing a number of rows. In one of the columns is an htmlCommandLink which passes some parameters to a backing bean and the return response is an Excel file fetched from somewhere else.

      =======================
      | link | data | data | ....
      =======================
      | link | data | data | ....
      =======================
      ...

      The link code looks like:

      <a4j:htmlCommandLink action="#{myBean.pushAccountSummary}" value="Open " >
       <f:param name="cId" value="#{rep.filename}" />
       <f:param name="cType" value="#{rep.type}" />
      </a4j:htmlCommandLink>
      


      So the first time I'm in the page, I click on a link and the appropriate request is sent back and the appropriate file is returned for me to open/save.

      Second time I click on a different row's link, I get the same open/save dialog from IE6... for the last row.

      No matter what row I use, I keep getting the first file I opened. This works correctly in FireFox 2 & 3, but not IE6 ( I don't have IE7 installed, so I can't test it there).

      I used Fiddler, and I noticed these parameters were sent back:

      (I've inserted linebreaks after the '&'s)
      repTableFormAccountSummary%3A__a__=empty&
      repTableFormAccountSummary=repTableFormAccountSummary&
      autoScroll=&
      repTableFormAccountSummary%3A_idcl=repTableFormAccountSummary%3AaccountSummaryReportTable%3A1%3A_id588&repTableFormAccountSummary%3A_link_hidden_=&
      cId=BCSLE1701_033170094101_2007_12_20071231180142_Complete.xls&
      cType=overhead
      


      The 2nd click sent back:
      repTableFormAccountSummary%3A__a__=empty&
      repTableFormAccountSummary=repTableFormAccountSummary&
      autoScroll=&
      repTableFormAccountSummary%3A_idcl=repTableFormAccountSummary%3AaccountSummaryReportTable%3A0%3A_id588&
      repTableFormAccountSummary%3A_link_hidden_=&
      cId=BCSLE1701_033170094101_2007_12_20071231180142_Complete.xls&
      cType=overhead&
      cId=BCSLE1701_033170015281_2007_11_20071130180129_Complete.xls&
      cType=overhead
      


      It's doubling up the parameters!! And as I keep clicking, the request post-back keeps getting longer.

      Any idea how to get this to stop? Thanks in advance!