5 Replies Latest reply on Nov 6, 2008 9:43 AM by Giuseppe Scamorza

    Action not work after ie7 update

    Giuseppe Scamorza Newbie

      I write a very simple test project (a page with a button that call another page)
      echo.jsp

      <%@ taglib uri="http://richfaces.org/a4j" prefix="a4j"%>
      <%@ taglib uri="http://richfaces.org/rich" prefix="rich"%>
      <%@ taglib uri="http://java.sun.com/jsf/html" prefix="h"%>
      <%@ taglib uri="http://java.sun.com/jsf/core" prefix="f"%>
      <html>
       <head>
       <title>repeater </title>
       </head>
       <body>
       <f:view>
       <h:form>
       <a4j:commandButton action="next" id="button" value="Next" />
       </h:form>
       </f:view>
       </body>
      </html>
      

      second.jsp
      <%@ taglib uri="http://richfaces.org/a4j" prefix="a4j"%>
      <%@ taglib uri="http://richfaces.org/rich" prefix="rich"%>
      <%@ taglib uri="http://java.sun.com/jsf/html" prefix="h"%>
      <%@ taglib uri="http://java.sun.com/jsf/core" prefix="f"%>
      
      <html>
       <head>
       <title>JSP Page</title>
       </head>
       <body>
       <h2>Ok</h2>
       </body>
      </html>
      

      faces-config.xml
      <?xml version='1.0' encoding='UTF-8'?>
       <!DOCTYPE faces-config PUBLIC "-//Sun Microsystems, Inc.//DTD JavaServer Faces Config
      1.1//EN"
       "http://java.sun.com/dtd/web-facesconfig_1_1.dtd">
      <faces-config>
       <lifecycle>
       <phase-listener>org.exadel.jsf.PhaseTracker</phase-listener>
       </lifecycle>
       <navigation-rule>
       <from-view-id>/echo.jsp</from-view-id>
       <navigation-case>
       <from-outcome>next</from-outcome>
       <to-view-id>/second.jsp</to-view-id>
       </navigation-case>
       </navigation-rule>
      </faces-config>
      


      web.xml it's the same of richfaces echo example.
      When i launch (under netbeans) this application and i testing with firefox all work fine.
      Also with a fresh install of ie7 all working fine...but after installing the explorer's patch kb956390 it break to work: i see only a blank page, and explorer say me that there is an error

      line: 168
      character: 452
      Error : Incompatibilità tra tipi [sorry, but i use the italian version of ie7]
      code: 0
      


      I try using some other pc, also with fresh windows install, but always the same situation (after patch blank page + error)...how can i resolve?

      PS: sorry for my bad english ;-)