0 Replies Latest reply on Aug 6, 2006 4:46 PM by aozoren

    Eclipse & expanded deployment

    aozoren Newbie

      Hi - I am trying get JBoss hot deploy the Eclipse seam project but so far I am not successful. Any hint is appreciated..

      The last error I am getting is as follows..

      22:52:58,241 FATAL [DatasourceConnectionProvider] Could not find datasource: java:/oneDatasource
      javax.naming.NameNotFoundException: oneDatasource not bound

      I don't understand why I am getting this because the oneDatasource seems to have deployed according to these log entries..

      22:52:09,907 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=oneDatasource' to JNDI name 'java:oneDatasource'

      One thing I notice is that it looks for a "/" before jndi name when it fails.

      jboss-service.xml is as follows..


      deploy/,
      file:/Users/ali/Java5/dev8/workspace/one/bin


      the directory structure is as follows..

      +bin
      ++one.ear
      components.properties
      hibernate.cfg.xml
      jboss.seam.jar
      jbpm.3.1.1.jar
      jbpm.cfg.xml
      +++META-INF
      application.xml
      components.properties
      ejb-jar.xml
      jboss-app.xml
      jboss-beans.xml
      persistence.xml
      MANIFEST.MF
      ++one.war
      seam.properties
      +++META-INF
      MANIFEST.MF
      +++WEB-INF
      components.xml
      web.xml
      faces-config.xml
      ++one.ejb3 // for .class files
      +src
      ..


      application.xml is as follows..

      <application xmlns="http://java.sun.com/xml/ns/j2ee" version="1.4"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://java.sun.com /xml/ns/j2ee
      http://java.sun.com/xml/ns/j2ee/application_1_4.xsd">

      <display-name>One</display-name>
      One Software

      one.ejb3



      <web-uri>one.war</web-uri>
      <context-root>/one</context-root>



      jboss-seam.jar


      jbpm-3.1.1.jar




      components.properties is as follows..

      myFacesLifecycleBug false
      embeddedEjb true
      jndiPattern #{ejbName}/local

      jboss-beans.xml is as follows..

      <?xml version="1.0" encoding="UTF-8"?>

      <deployment xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="urn:jboss:bean-deployer bean-deployer_1_0.xsd"
      xmlns="urn:jboss:bean-deployer:2.0">


      com.mysql.jdbc.Driver
      jdbc:mysql://localhost/seamtest?useUnicode=true&characterEncoding=UTF-8
      root
      java:/oneDatasource
      0
      10
      1000
      100000












      persistence.xml is as follows..


      <persistence-unit name="oneDatabase">
      org.hibernate.ejb.HibernatePersistence
      <jta-data-source>java:/oneDatasource</jta-data-source>








      </persistence-unit>


      and components.xml is as follows..




      true
      @myFacesLifecycleBug@
      @jndiPattern@


      <!-- 120 second conversation timeout -->

      120000



      ordermanagement1.jpdl.xml
      checkout.jpdl.xml, newuser.jpdl.xml