2 Replies Latest reply on Jun 12, 2007 12:48 PM by Bradley Smith

    EntityHome doesn't work on JBoss 4.0.4 EJB3 RC8

    Bradley Smith Master

      I ran into the problem described here -> http://opensource.atlassian.com/projects/hibernate/browse/HHH-1938
      while trying to use EntityHome in Seam 1.2.1 on JBoss 4.0.4 EJB3 RC8.

      I tried the suggested changes with still no success. I believe that my version of JBoss + EJB3 is the culprit here.

      My question is ...

      Is there some sort of known Seam 1.X + JBoxx 4.0.X compatibility matrix available? For example...

      Seam 1.2.1 Requires JBoss 4.0.4 / EJB3 8. etc...
      - EntityHome requires JBoss 4.0.5 / EJB RC9, etc...

      For tinkering around, I can try any version of JBoss, to put an application into production, I am constrained to use JBoss 4.0.4 for now and will be able to use JBoss 4.0.5 in the near future - it's going to be a long time (many months (> 6-9) until we look seriously at using 4.2.0 probably so knowing the limitations of the framework w.r.t. a particular JBoss AS platform will be a big help in making design choices in our applications.

      Thanks,
      Brad Smith