0 Replies Latest reply on Jul 17, 2007 4:02 PM by kelly goedert

    seam deploy hangs on jboss 4.2

    kelly goedert Apprentice

      Hi,

      I´m trying to deploy an application with seam 2 in jboss 4.2.
      The deploy hangs when tomcat is about to start. What may be causing the problem? I had this application being deployed correctly with seam 1.2 and jboss 4.0.5.

      Here is my web.xml
      --------------------
      <web-app>
      sig

      <context-param>
      <param-name>javax.faces.CONFIG_FILES</param-name>
      <param-value>
      /WEB-INF/conf/faces-config.xml,/WEB-INF/conf/navigation.xml
      </param-value>

      Comma separated list of URIs of (additional) faces config
      files. (e.g. /WEB-INF/my-config.xml) See JSF 1.0 PRD2,
      10.3.2

      </context-param>
      <context-param>
      <param-name>javax.faces.STATE_SAVING_METHOD</param-name>
      <param-value>client</param-value>

      State saving method: "client" or "server" (= default) See
      JSF Specification 2.5.2

      </context-param>
      <context-param>
      <param-name>org.apache.myfaces.ALLOW_JAVASCRIPT</param-name>
      <param-value>true</param-value>

      This parameter tells MyFaces if javascript code should be
      allowed in the rendered HTML output. If javascript is
      allowed, command_link anchors will have javascript code that
      submits the corresponding form. If javascript is not
      allowed, the state saving info and nested parameters will be
      added as url parameters. Default: "true"

      </context-param>
      <context-param>
      <param-name>org.apache.myfaces.DETECT_JAVASCRIPT</param-name>
      <param-value>false</param-value>
      </context-param>
      <context-param>
      <param-name>org.apache.myfaces.PRETTY_HTML</param-name>
      <param-value>true</param-value>

      If true, rendered HTML code will be formatted, so that it is
      "human readable". i.e. additional line separators and
      whitespace will be written, that do not influence the HTML
      code. Default: "true"

      </context-param>
      <context-param>
      <param-name>org.apache.myfaces.AUTO_SCROLL</param-name>
      <param-value>true</param-value>

      If true, a javascript function will be rendered that is able
      to restore the former vertical scroll on every request.
      Convenient feature if you have pages with long lists and you
      do not want the browser page to always jump to the top if
      you trigger a link or button action that stays on the same
      page. Default: "false"

      </context-param>
      <context-param>
      <param-name>javax.faces.DEFAULT_SUFFIX</param-name>
      <param-value>.xhtml</param-value>
      </context-param>
      <context-param>
      <param-name>facelets.DEVELOPMENT</param-name>
      <param-value>true</param-value>
      </context-param>
      <context-param>
      <param-name>facelets.LIBRARIES</param-name>
      <param-value>
      /WEB-INF/conf/myComponents.taglib.xml
      </param-value>
      </context-param>

      <filter-name>Seam Filter</filter-name>
      <filter-class>org.jboss.seam.servlet.SeamFilter</filter-class>


      <filter-mapping>
      <filter-name>Seam Filter</filter-name>
      <url-pattern>/*</url-pattern>
      </filter-mapping>


      <listener-class>
      org.jboss.seam.servlet.SeamListener
      </listener-class>


      <!-- JSF -->


      <listener-class>
      com.sun.faces.config.ConfigureListener
      </listener-class>


      <servlet-name>Faces Servlet</servlet-name>
      <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
      <load-on-startup>1</load-on-startup>


      <servlet-name>Seam Resource Servlet</servlet-name>
      <servlet-class>
      org.jboss.seam.servlet.ResourceServlet
      </servlet-class>



      <!-- Faces Servlet Mapping -->
      <servlet-mapping>
      <servlet-name>Faces Servlet</servlet-name>
      <url-pattern>*.sig</url-pattern>
      </servlet-mapping>

      <servlet-mapping>
      <servlet-name>Seam Resource Servlet</servlet-name>
      <url-pattern>/seam/resource/*</url-pattern>
      </servlet-mapping>
      <session-config>
      <session-timeout>10</session-timeout>
      </session-config>
      <login-config>
      <auth-method>BASIC</auth-method>
      </login-config>

      </web-app>

      And this is my components.xml
      ------------------------------------
      <components xmlns="http://jboss.com/products/seam/components"
      xmlns:core="http://jboss.com/products/seam/core"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:drools="http://jboss.com/products/seam/drools"
      xmlns:web="http://jboss.com/products/seam/web"
      xsi:schemaLocation=
      "http://jboss.com/products/seam/core http://jboss.com/products/seam/core-2.0.xsd
      http://jboss.com/products/seam/drools http://jboss.com/products/seam/drools-2.0.xsd
      http://jboss.com/products/seam/components http://jboss.com/products/seam/components-2.0.xsd">

      <core:init jndi-pattern="sig/#{ejbName}/local"/>
      <core:ejb installed="false"/>
      <core:Jbpm>
      <core:process-definitions>
      ticketProcess.jpdl.xml
      </core:process-definitions>
      <core:process-definitions>
      request/request.jpdl.xml
      </core:process-definitions>
      </core:Jbpm>
      <drools:rule-base name="securityRules">
      <drools:rule-files>
      /security.drl
      </drools:rule-files>
      </drools:rule-base>
      <security:identity authenticate-method="#{authenticator.authenticate}"/>

      true

      <web:ajax4jsf-filter force-parser="true"
      enable-cache="true"
      log4j-init-file="custom-log4j.xml"
      url-pattern="*.seam"/>


      No error messages are presented. The deploy just hangs.
      Can anybody help?

      Thanks