0 Replies Latest reply on Oct 26, 2007 8:16 AM by Lisa Mark

    Seam-Spring XML namespace problem

    Lisa Mark Newbie

      Hi,
      Please help me with the following exception when trying to run Seam+Spring example (1.2.1 GA) under Eclipse-Exadel and Tomcat

      org.springframework.beans.factory.parsing.BeanDefinitionParsingException:
      Configuration problem: Unable to locate Spring NamespaceHandler for XML schema
       namespace [http://jboss.com/products/seam/spring-seam]
      Offending resource: ServletContext resource [/WEB-INF/applicationContext.xml]
      


      ...

      ERROR [XmlWebApplicationContext] Exception thrown from ApplicationListener handling ContextClosedEvent
      java.lang.IllegalStateException: ApplicationEventMulticaster not initialized - call 'refresh' before multicasting events via the context: org.springframework.web.context.support.XmlWebApplicationContext@1c0bec5: display name [Root WebApplicationContext]; startup date [Fri Oct 26 14:10:13 CEST 2007]; root of context hierarchy
      


      Applicationcontext.xml
      <?xml version="1.0" encoding="UTF-8"?>
      <beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:aop="http://www.springframework.org/schema/aop"
       xmlns:util="http://www.springframework.org/schema/util"
       xmlns:seam="http://jboss.com/products/seam/spring-seam"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xmlns:tx="http://www.springframework.org/schema/tx"
       xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
       http://www.springframework.org/schema/aop http://www.springframework.org/schema/aop/spring-aop-2.0.xsd
       http://www.springframework.org/schema/util http://www.springframework.org/schema/util/spring-util-2.0.xsd
       http://jboss.com/products/seam/spring-seam http://jboss.com/products/seam/spring-seam-1.2.xsd
       http://www.springframework.org/schema/tx http://www.springframework.org/schema/tx/spring-tx-2.0.xsd"
       default-lazy-init="true">
      



      Any help is highly appreciated.

      Thanks