4 Replies Latest reply on May 7, 2009 5:19 AM by ezani abdul halim

    Cannot run JBossESB 4.4.GA on JBossAS 4.2.2.GA

    ezani abdul halim Newbie

      Hi there

      I have just installed a fresh copy of JBoss-4.2.2.GA on C:\JBoss-4.2.2.GA and it started up without errors. Then I downloaded and installed JBossESG-4.4.GA to C:\JBossESG-4.4.GA. I created a default deployment.properties file in the C:\JBossESG-4.4.GA\install folder and pointed to my JBoss Server path. Finally I ran 'ant' on install folder to copy the necessary ESB files to the JBoss Server directory and got the message : BUILD SUCCESSFUL.

      However, this time when I re-started my JBoss 4.2.2 server, I got a deployment log full of errors as follows:-

      12:04:52,671 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
      
      --- MBeans waiting for other MBeans ---
      ObjectName: jboss.esb:deployment=jbossesb.esb
       State: FAILED
       Reason: java.lang.NoSuchMethodError: javassist.scopedpool.ScopedClassPool.<ini
      t>(Ljava/lang/ClassLoader;Ljavassist/ClassPool;Ljavassist/scopedpool/ScopedClass
      PoolRepository;Z)V
       I Depend On:
       jboss.esb:service=MessageStoreDatabaseInitializer
       jboss.esb.destination:service=Queue,name=DeadMessageQueue
       jboss.jca:service=DataSourceBinding,name=JBossESBDS
       jboss.esb.destination:service=Queue,name=OperationsResultCollectorQueue
       jboss.esb.destination:service=Queue,name=OperationsCollectorQueue
       jboss.esb.destination:service=Queue,name=DataCollectorQueue
       Depends On Me:
       jboss.esb:deployment=jbpm.esb
       jboss.esb:deployment=jbrules.esb
       jboss.esb:deployment=management.esb
       jboss.esb:deployment=slsb.esb
       jboss.esb:deployment=smooks.esb
       jboss.esb:deployment=soap.esb
       jboss.esb:deployment=spring.esb
      
      ObjectName: jboss.esb:deployment=jbpm.esb
       State: NOTYETINSTALLED
       I Depend On:
       jboss.jca:service=DataSourceBinding,name=JbpmDS
       jboss.esb:service=JBPMDatabaseInitializer
       jboss.esb:deployment=jbossesb.esb
      
      ObjectName: jboss.esb:deployment=jbrules.esb
       State: NOTYETINSTALLED
       I Depend On:
       jboss.esb:deployment=jbossesb.esb
      
      ObjectName: jboss.esb:deployment=management.esb
       State: NOTYETINSTALLED
       I Depend On:
       jboss.esb.console.destination:service=Queue,name=InvokerFilerQueue
       jboss.esb:deployment=jbossesb.esb
       jboss.esb.console.destination:service=Queue,name=OperationsFilerQueue
       jboss.esb.console.destination:service=Queue,name=DataFilerQueue
       jboss.jca:service=DataSourceBinding,name=ManagementDS
       jboss.jca:service=DataSourceBinding,name=juddiDB
      
      ObjectName: jboss.esb:deployment=slsb.esb
       State: NOTYETINSTALLED
       I Depend On:
       jboss.esb:deployment=jbossesb.esb
      
      ObjectName: jboss.esb:deployment=smooks.esb
       State: NOTYETINSTALLED
       I Depend On:
       jboss.esb.destination:service=Topic,name=org.jboss.soa.esb.transformation.Up
      date
       jboss.esb:deployment=jbossesb.esb
      
      ObjectName: jboss.esb:deployment=soap.esb
       State: NOTYETINSTALLED
       I Depend On:
       jboss.esb:deployment=jbossesb.esb
      
      ObjectName: jboss.esb:deployment=spring.esb
       State: NOTYETINSTALLED
       I Depend On:
       jboss.esb:deployment=jbossesb.esb
      
      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.esb:deployment=jbossesb.esb
       State: FAILED
       Reason: java.lang.NoSuchMethodError: javassist.scopedpool.ScopedClassPool.<ini
      t>(Ljava/lang/ClassLoader;Ljavassist/ClassPool;Ljavassist/scopedpool/ScopedClass
      PoolRepository;Z)V
       I Depend On:
       jboss.esb:service=MessageStoreDatabaseInitializer
       jboss.esb.destination:service=Queue,name=DeadMessageQueue
       jboss.jca:service=DataSourceBinding,name=JBossESBDS
       jboss.esb.destination:service=Queue,name=OperationsResultCollectorQueue
       jboss.esb.destination:service=Queue,name=OperationsCollectorQueue
       jboss.esb.destination:service=Queue,name=DataCollectorQueue
       Depends On Me:
       jboss.esb:deployment=jbpm.esb
       jboss.esb:deployment=jbrules.esb
       jboss.esb:deployment=management.esb
       jboss.esb:deployment=slsb.esb
       jboss.esb:deployment=smooks.esb
       jboss.esb:deployment=soap.esb
       jboss.esb:deployment=spring.esb
      
      
      12:04:53,562 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8
      080
      12:04:53,609 INFO [AjpProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
      12:04:53,625 INFO [Server] JBoss (MX MicroKernel) [4.2.2.GA (build: SVNTag=JBos
      s_4_2_2_GA date=200710221139)] Started in 55s:250ms
      


      What am I doing wrong?

        • 1. Re: Cannot run JBossESB 4.4.GA on JBossAS 4.2.2.GA
          ezani abdul halim Newbie

          Sorry, the first line in console when the error occurred is as follows :-

          12:27:39,109 WARN [ServiceController] Problem starting service jboss.esb:deployment=jbossesb.esb
          java.lang.NoSuchMethodError: javassist.scopedpool.ScopedClassPool.<init>(Ljava/lang/ClassLoader;Ljavassist/ClassPool;Ljavassist/scopedpool/ScopedClassPoolRepository;Z)V
           at org.jboss.aop.classpool.AOPClassPool.<init>(AOPClassPool.java:66)
           at org.jboss.aop.classpool.AOPClassPool.<init>(AOPClassPool.java:56)
          


          • 2. Re: Cannot run JBossESB 4.4.GA on JBossAS 4.2.2.GA
            Tom Fennelly Master

            The NoSuchMethodError suggests something unusual with the AS. Your AS was unmodified before installing the ESB, right? Absolutely nothing?

            Can you list the contents of the server/default/deploy folder. Also show the contents deployment.properties file. Would be usefull to see more info from the server.log. Can you send that please.

            Can you try running the ESB Server directly from the ESB distribution please.

            • 3. Re: Cannot run JBossESB 4.4.GA on JBossAS 4.2.2.GA
              ezani abdul halim Newbie

              Thanks, tfennelly. It is a fresh install of JBoss-4.2.2.GA. I deleted the C:\JBoss-4.2.2.GA folder and uncompressed the JBoss-4.2.2.GA.zip I downloaded twice and tested with a run.bat from the JBoss\bin directory...twice.

              I then uncompressed the JBossESB-4.4.GA.zip setup file to C:\JBossESB-4.4.GA, copied the deployment.properties example file given in the ESB's \install directory and created my own. Simple file..with just your default paths to JBoss AS and Tomcat..and yes..I know about the "\" and "/" bug and "no spaces" in the folder name.

              Here's the deployment.properties file:

              org.jboss.esb.server.home=C:/jboss-4.2.2.GA
              org.jboss.esb.server.config=default
              org.jboss.esb.tomcat.home=/apache-tomcat-5.5.20
              


              Here's what's in C:\JBoss-4.2.2.GA\server\default\deploy:-

              ejb3.deployer
              http-invoker.sar
              jboss-aop-jdk50.deployer
              jboss-bean.deployer
              jbossesb.esb
              jbossesb.sar
              jboss-web.deployer
              jbossws.sar
              jbpm.esb
              jbrules.esb
              jms
              jmx-console.war
              management
              slsb.esb
              smooks.esb
              soap.esb
              soapui-client.sar
              spring.esb
              uuid-key-generator.sar
              bsh-deployer.xml
              cache-invalidation-service.xml
              client-deployer-service.xml
              ...bla...bla

              (There are no ear files or any other war or jar files from any Java apps - its a fresh install)

              Funny thing is that I did the same with JBoss-4.2.3.GA server and JBossESB-4.5.GA and got exactly the same result.

              I'm beginning to think that I must have copied, modified or deleted some files in my Java JDK (1.5.0-r11) /JRE (1.5.0-r14). Could that be the problem?

              Or could it be javaassist.jar ?

              In the JBossESB's lib folder, there are quite a number of jar files there. Should I copy and overwrite them to JBoss\server\default\lib ?

              [Note - I don't use JBossESB Server. I need to use my EJB3s).

              • 4. Re: Cannot run JBossESB 4.4.GA on JBossAS 4.2.2.GA
                ezani abdul halim Newbie

                Ok, got the answer which I'll share with everyone :-


                "java.lang.NoSuchMethodError: javax.servlet.ServletContext.getContextPath()Ljava/lang/String;

                This exception results from attempting to use Java EE 5 components (such as JSF 1.2) in a J2EE 1.4 environment. Either the container does not support Java EE 5 or you have the 2.4 servlet API somewhere in the runtime path."

                Courtesy of : http://mojavelinux.com/wiki/doku.php?id=java:developmentnotes