4 Replies Latest reply on Dec 16, 2009 11:31 AM by Michael Heinen

    rerender does not work after migration from 3.1.5 to 3.3.2

    Michael Heinen Newbie

      Many Ajax commands are not rerendering anything after updating from 3.1.5 to 3.3.2.
      The Listener is called successfully and the expected html is sent but screen is not updated anymore.

       

      a4j:log contains this line:
      {code}error[11:11:10,415]: New node for ID aspectform:a4jAspectList is not present in response{code}

       

      JSP (how can I add linebreaks in code tags?):
      {code:xml}
      <h:form id="actionMenuForm">
      ...
      <a4j:region id="aActionShowAspectListRegion"
                      renderRegionOnly="false"
                      rendered="#{MyController.aspectsButtonAvailable}">
        <a4j:commandButton id="aShowAspectList"
                           reRender="a4jAspectList"
                           oncomplete="enableSubmit();showProgressBar(false);closeActionsMenu();">
          <a4j:actionparam name="apAspectid"
                           assignTo="#{AspectController.aspectId}"
                           value="#{FieldConfigurationController.aspectListTextType}"
                           actionListener="#{AspectController.showAllAspects}"/>

        </a4j:commandButton>
      </a4j:region>
      ...
      </h:form>

      <h:form id="aspectform"
      ...
      <a4j:outputPanel id="a4jAspectList">
        <t:panelGroup id="aspectListPg" rendered="#{!empty requestScope['aspectListOpen']}">
      ...
      </h:form>
      {code}


      I updated also
      myFaces from 1.1.6 to 1.2.8
      tomahawk from 1.1.7 to tomahawk12-1.1.9
      tiles from 1 to 2.0.5

      The a4j:log output is attached.
      I removed some html content to reduce size.

      Any ideas?