2 Replies Latest reply on Apr 27, 2010 4:48 AM by Jean Deruelle

    Comet connection issue on JBoss 5.1.0 GA

    Nattanond Sangvanphant Newbie

      Hi,

      I'm having a problem configuring the Comet connection on JBoss 5.1.0 GA.

      I decided to use APR connector, and have already installed the native library.

      The first time the client connects to the server, everything seems fine.

      However, when the time out event occurs, I get the null pointer exception instead of an error comet event.

       

      The server side implements org.jboss.servlet.http.HttpEventServlet as

       

      public class PushServlet extends HttpServlet implements HttpEventServlet

       

       

       

      The server log is as follows

       

      09:50:23,316 INFO [PushServlet] new event

      09:50:23,318 INFO [PushServlet] Session: abc has been connected

      09:50:23,349 INFO [PushServlet] new event

      09:50:23,349 INFO [PushServlet] Begin for session: abc

      09:50:34,729 ERROR [CoyoteAdapter] An exception or error occurred in the container during the request processing

      java.lang.NullPointerException

      at org.apache.catalina.valves.ValveBase.event(

      ValveBase.java:199)

      at org.jboss.web.tomcat.security.SecurityAssociationValve.event(

      SecurityAssociationValve.java:345)

      at org.apache.catalina.valves.CometConnectionManagerValve.event(

      CometConnectionManagerValve.java:294)

      at org.jboss.web.tomcat.security.JaccContextValve.event(

      JaccContextValve.java:127)

      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(

      SecurityContextEstablishmentValve.java:128)

      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.event(

      SecurityContextEstablishmentValve.java:95)

      at org.apache.catalina.core.StandardHostValve.event(

      StandardHostValve.java:178)

      at org.apache.catalina.valves.ValveBase.event(

      ValveBase.java:199)

      at org.jboss.web.tomcat.service.jca.CachedConnectionValve.event(

      CachedConnectionValve.java:186)

      at org.apache.catalina.core.StandardEngineValve.event(

      StandardEngineValve.java:128)

      at org.apache.catalina.connector.CoyoteAdapter.event(

      CoyoteAdapter.java:232)

      at org.apache.coyote.http11.Http11AprProcessor.event(

      Http11AprProcessor.java:789)

      at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.event(

      Http11AprProtocol.java:543)

      at org.apache.tomcat.util.net.AprEndpoint$Worker.run(

      AprEndpoint.java:2030)

      at java.lang.Thread.run(Unknown Source)

       

       

       

      I also noted that this issue starts when I add the webservice functionality to the server.

      Has anyone experienced the same or similar issue?

       

      Thank you.