0 Replies Latest reply on Mar 2, 2010 8:39 AM by Koray Cetinbas

    WSRP producer does not accept registration

    Koray Cetinbas Newbie

      Hi all,

       

      I have a strange problem. I have a 2.6.4 versioned JBoss portal as a producer and 2.7.2 version portal as consumer.

      At first everything goes well and i can consume remote portlets successfully

       

      After some time, if i restart the consumer portal for example, i cannot reregister to the portal again.

      There is an error such that on the consumer logs

                   Couldn't register with producer 'Koray'
                15:32:32,765 ERROR [CallImpl] Call invocation failed

                javax.xml.rpc.soap.SOAPFaultException: Could not register consumer named 'NLRUA4
                WS10.mydomain.com.'. Consumer named 'NLRUA4WS10.mydomain.com.' has alr
                eady been registered with the same set of registration properties. Registration
                rejected!

       

      So i go ahead and erase the local registration info from the consumer.

      The same error.

       

      I delete the consumer and define a new consumer. (i leave no consumers at all after some time)

      The same problem.. Even though i do not have a consumer,  i still get this problem

       

      And no matter what i do, i cannot reregister again to the producer..

       

      What can i do to correct this. This has happened to me on a few more machines and i do not know a way to overcome this problem.

      I really need to make this work properly

       

      Any help is greately appreciated