4 Replies Latest reply on Mar 4, 2010 12:11 PM by Radhakrishnan Sethuraman

    Weblogic10.3 and Richfaces4

    Radhakrishnan Sethuraman Newbie

      I am deploying a sample application with JSF2 and Richfaces4-alpha. I am getting the following exception :

      Mar 3, 2010 11:20:29 PM com.sun.faces.config.AnnotationScanner processClasspath
      SEVERE: Unable to process annotations for url, zip:C:/ORACLE/Middleware/user_projects/domains/wls11_admin/servers/AdminServer/tmp/_WL_user/poc/jje3vo/war/WEB-INF/lib/richfacesimpl.jar!/META-INF/resource-handler.faces-config.xml. Reason: java.io.FileNotFoundException: zip:C:/ORACLE/Middleware/user_projects/domains/wls11_admin/servers/AdminServer/tmp/_WL_user/poc/jje3vo/war/WEB-INF/lib/richfacesimpl.jar
      Mar 3, 2010 11:20:29 PM com.sun.faces.config.AnnotationScanner processClasspath
      SEVERE:
      java.io.FileNotFoundException: zip:C:/ORACLE/Middleware/user_projects/domains/wls11_admin/servers/AdminServer/tmp/_WL_user/poc/jje3vo/war/WEB-INF/lib/richfacesimpl.jar
      at weblogic.utils.zip.ZipURLConnection.connect(Handler.java:78)
      at weblogic.utils.zip.ZipURLConnection.getInputStream(Handler.java:53)
      at sun.net.www.protocol.jar.URLJarFile.retrieve(URLJarFile.java:195)
      at sun.net.www.protocol.jar.URLJarFile.getJarFile(URLJarFile.java:50)
      at sun.net.www.protocol.jar.JarFileFactory.get(JarFileFactory.java:78)
      at sun.net.www.protocol.jar.JarURLConnection.connect(JarURLConnection.java:104)
      at sun.net.www.protocol.jar.JarURLConnection.getJarFile(JarURLConnection.java:71)
      at com.sun.faces.config.AnnotationScanner.processClasspath(AnnotationScanner.java:290)
      at com.sun.faces.config.AnnotationScanner.getAnnotatedClasses(AnnotationScanner.java:215)
      at com.sun.faces.config.ConfigManager$AnnotationScanTask.call(ConfigManager.java:765)
      at com.sun.faces.config.ConfigManager$AnnotationScanTask.call(ConfigManager.java:736)


      But I see the jar in the location. I did search internet. I didnt come accross any issue like this. This is also not reported in Rich or Ice faces forums. Am I doing something wrong? Please advice.


      Note: I have asked the same question in weblogic forum. wanted to know if Richfaces users have got this before and a solution is available.

       

      Thanks.