2 Replies Latest reply on Apr 6, 2009 11:27 AM by Brad Warren

    extendedDataTable won't render

    Brad Warren Novice

      I have a case where extendedDataTable is not working. I have tried it with a rich:dataTable and it works fine. When I switch to extendedDataTable the table just displays the loading icon forever.

      I have another page with an extendedDataTable and it works fine. I actually cut and pasted the tags and most of the backing bean code and changed the names to make sure they were being used the same way. The working extendedDataTable uses a subclass of DataModel, as does the one not working (and the rich:dataTable). The surrounding tags on both pages are also the same (<h:form>, etc.) The browser status bar says it's downloading css files, which are the same ones referenced by the working extendedDataTable. Anyone see anything I'm doing wrong here?

       <rich:extendedDataTable value="#{viewConnectionsBean.connectionDataModel}"
       var="row" height="425px" width="100%" id="connTable"
       rowKeyVar="rowIndex"
       selectedClass="tableRTDHighlight"
       styleClass="tableRTD"
       headerClass="tableRTDHeader">
      


      The working rich:dataTable

       <rich:dataTable value="#{viewConnectionsBean.connectionDataModel}"
       var="row" width="100%" id="connTable"
       styleClass="tableRTD"
       headerClass="tableRTDHeader">
      


      The working extendedDataTable (on another page)

       <rich:extendedDataTable value="#{rtdBackingBean.departureDataModel}"
       var="row" height="425px" width="100%"
       id="rtdTable"
       rowKeyVar="rowIndex"
       selectedClass="tableRTDHighlight"
       styleClass="tableRTD"
       headerClass="tableRTDHeader">