4 Replies Latest reply on May 4, 2010 8:48 AM by Wolfgang Knauf

    Urgent: Bulgarian  character set problem

    Shibin Thomas Newbie

      Hai all ,

      I have a problem while inserting data to oracle,  when we using Bulgarian  or Greece
      characters. We have ti insert all countries PIN/ZIP into a  Option table .

      But when we run sql script with special characters like МП Летище Бургас ( Bulgarian )
      INSERT INTO
      OPTION(LANGUAGE,VERSION,TYPE,module,CODE,description,bemerkung,description2,descrip
      tion3) VALUES('DE','SCPRLD','122','ALL','BG001002','МП Летище  Бургас','','','ext');
      or    Β΄ ΘΕΣΣΑΛΟΝΙΚΗΣ ( Griechenland - greece  )
      INSERT INTO
      beoatlas2.OPTION(LANGUAGE,VERSION,TYPE,module,CODE,description,bemerkung,description2,descrip
      tion3) VALUES('DE','SCPRLD','122','ALL','GR002002',N'Β΄  ΘΕΣΣΑΛΟΝΙΚΗΣ','','','ext');
      it returns as ?????? marks .
      I am also tried to insert using java and plssql developer . I saved this file in unicode character set format .
      And tried to insert line by line
      bufferedFileReader = new BufferedReader(new InputStreamReader(new FileInputStream("MSSQL.sql"), "unnicode"));
      then also it displaying as ???????
      Oracle data base character set is WE8ISO8859P1

      Any sujections are appreciated . Please replay your idieas.
      Thanks & Regards
      Shibin Thomas