1 Reply Latest reply on May 6, 2010 1:10 PM by Clebert Suconic

    Version Compatibilities for HQ Resource Adaptor

    Ben Schofield Novice

      This is a follow on question to a previous thread. https://community.jboss.org/thread/151475

       

      What can the HornetQ user community expect in regards to the JCA resource adaptor compatiblity with different versions of remote stand alone HornetQ installs?

       

      For example, if I build an enterprise messaging system based on HornetQ 2.0 stand alone servers and I have multiple JBoss AS 5.1 servers connecting to the HQ servers via the resource adaptor.  Can I expect to use the HornetQ 2.1 resource adaptor in my JBoss instances no problems?  Then later down the road be able to upgrade my HornetQ 2.0 stand alone servers to 3.0 without updating the HornetQ 2.1 resource adaptor in the JBoss clients?