2 Replies Latest reply on May 24, 2010 8:39 AM by Ami Khandeshi

    Having spring deployement issues on JBoss 6 (M3)

    Ami Khandeshi Newbie

      (ResourceContainer.invoker.nonDaemon-3) Initializing Spring root WebApplicationContext
      2010-05-21 16:12:32,857 ERROR [org.springframework.web.context.ContextLoader] (ResourceContainer.invoker.nonDaemon-3) Context initialization failed: org.springframework.context.ApplicationContextException: Failed to load custom context class [org.jboss.spring.vfs.context.VFSXmlWebApplicationContext]; nested exception is java.lang.ClassNotFoundException: org.jboss.spring.vfs.context.VFSXmlWebApplicationContext
      at org.springframework.web.context.ContextLoader.determineContextClass(ContextLoader.java:276) [:2.5.6]
      at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:243) [:2.5.6]
      at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:199) [:2.5.6]
      at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:45) [:2.5.6]
      at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3733) [:6.0.0.20100429-M3]
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4197) [:6.0.0.20100429-M3]
      at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeployInternal(TomcatDeployment.java:323) [:6.0.0.20100429-M3]
      at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeploy(TomcatDeployment.java:148) [:6.0.0.20100429-M3]
      at org.jboss.web.deployers.AbstractWarDeployment.start(AbstractWarDeployment.java:462) [:6.0.0.20100429-M3]
      at org.jboss.web.deployers.WebModule.startModule(WebModule.java:116) [:6.0.0.20100429-M3

       

      I am not sure where the problem, to best of my know all of the required spring classes are in commons/lib directory.  I am certain, it seem to be configuration issue.  Does anyone know how to solve this problem?

        • 1. Re: Having spring deployement issues on JBoss 6 (M3)
          Aaron Lee Newbie

          maybe you can try to put the spring jars under  your  web-inf/lib

          • 2. Re: Having spring deployement issues on JBoss 6 (M3)
            Ami Khandeshi Newbie

            I get following error message:

             

            error due to the following reason(s): java.lang.LinkageError: loader constraint violation in interface itable initialization: when resolving method "org.springframework.orm.hibernate3.LocalTransactionManagerLookup.getTransactionManager(Ljava/util/Properties;)Ljavax/transaction/TransactionManager;" the class loader (instance of org/jboss/classloader/spi/base/BaseClassLoader) of the current class, org/springframework/orm/hibernate3/LocalTransactionManagerLookup, and the class loader (instance of org/jboss/classloader/spi/base/BaseClassLoader) for interface org/hibernate/transaction/TransactionManagerLookup have different Class objects for the type javax/transaction/TransactionManager used in the signature -> org.jboss.deployers.client.spi.IncompleteDeploymentException:Summary of incomplete deployments

            error due to the following reason(s): java.lang.LinkageError: loader constraint violation in interface itable initialization: when resolving method "org.springframework.orm.hibernate3.LocalTransactionManagerLookup.getTransactionManager(Ljava/util/Properties;)Ljavax/transaction/TransactionManager;" the class loader (instance of org/jboss/classloader/spi/base/BaseClassLoader) of the current class, org/springframework/orm/hibernate3/LocalTransactionManagerLookup, and the class loader (instance of org/jboss/classloader/spi/base/BaseClassLoader) for interface org/hibernate/transaction/TransactionManagerLookup have different Class objects for the type javax/transaction/TransactionManager used in the signature -> org.jboss.deployers.client.spi.IncompleteDeploymentException:Summary of incomplete deployments

             

            Seems some jar conflicts, I am looking, if someone has an idea of the source of the problem, please help!

             

            Thanks