6 Replies Latest reply on Jul 27, 2010 6:09 AM by Rajyalakshmi Domathoti

    Not able to start the Jboss server

    Rajyalakshmi Domathoti Newbie

      While starting the server , i am getting this problem

      16:05:45,815 INFO  [ServerImpl] Starting JBoss (Microcontainer)...
      16:05:45,833 INFO  [ServerImpl] Release ID: JBoss [The Oracle] 5.1.0.GA (build: SVNTag=JBoss_5_1_0_GA date=200905221053)
      16:05:45,869 INFO  [ServerImpl] Bootstrap URL: null
      16:05:45,870 INFO  [ServerImpl] Home Dir: /opt/jboss-5.1.0.GA
      16:05:45,870 INFO  [ServerImpl] Home URL: file:/opt/jboss-5.1.0.GA/
      16:05:45,871 INFO  [ServerImpl] Library URL: file:/opt/jboss-5.1.0.GA/lib/
      16:05:45,872 INFO  [ServerImpl] Patch URL: null
      16:05:45,873 INFO  [ServerImpl] Common Base URL: file:/opt/jboss-5.1.0.GA/common/
      16:05:45,873 INFO  [ServerImpl] Common Library URL: file:/opt/jboss-5.1.0.GA/common/lib/
      16:05:45,873 INFO  [ServerImpl] Server Name: default
      16:05:45,874 INFO  [ServerImpl] Server Base Dir: /opt/jboss-5.1.0.GA/server
      16:05:45,874 INFO  [ServerImpl] Server Base URL: file:/opt/jboss-5.1.0.GA/server/
      16:05:45,875 INFO  [ServerImpl] Server Config URL: file:/opt/jboss-5.1.0.GA/server/default/conf/
      16:05:45,875 INFO  [ServerImpl] Server Home Dir: /opt/jboss-5.1.0.GA/server/default
      16:05:45,875 INFO  [ServerImpl] Server Home URL: file:/opt/jboss-5.1.0.GA/server/default/
      16:05:45,876 INFO  [ServerImpl] Server Data Dir: /opt/jboss-5.1.0.GA/server/default/data
      16:05:45,876 INFO  [ServerImpl] Server Library URL: file:/opt/jboss-5.1.0.GA/server/default/lib/
      16:05:45,876 INFO  [ServerImpl] Server Log Dir: /opt/jboss-5.1.0.GA/server/default/log
      16:05:45,877 INFO  [ServerImpl] Server Native Dir: /opt/jboss-5.1.0.GA/server/default/tmp/native
      16:05:45,877 INFO  [ServerImpl] Server Temp Dir: /opt/jboss-5.1.0.GA/server/default/tmp
      16:05:45,877 INFO  [ServerImpl] Server Temp Deploy Dir: /opt/jboss-5.1.0.GA/server/default/tmp/deploy
      16:06:05,330 INFO  [ServerImpl] Starting Microcontainer, bootstrapURL=file:/opt/jboss-5.1.0.GA/server/default/conf/bootstrap.xml
      16:06:11,537 INFO  [VFSCacheFactory] Initializing VFSCache [org.jboss.virtual.plugins.cache.CombinedVFSCache]
      16:06:11,603 INFO  [VFSCacheFactory] Using VFSCache [CombinedVFSCache[real-cache: null]]
      16:06:14,707 INFO  [CopyMechanism] VFS temp dir: /opt/jboss-5.1.0.GA/server/default/tmp
      16:06:15,133 INFO  [ZipEntryContext] VFS force nested jars copy-mode is enabled.
      16:06:38,535 INFO  [ServerInfo] Java version: 1.5.0_16,Sun Microsystems Inc.
      16:06:38,535 INFO  [ServerInfo] Java Runtime: Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b02)
      16:06:38,535 INFO  [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.5.0_16-b02,Sun Microsystems Inc.
      16:06:38,536 INFO  [ServerInfo] OS-System: Linux 2.6.18-128.1.10.el5.xs5.5.0.51xen,i386
      16:06:38,536 INFO  [ServerInfo] VM arguments: -Dprogram.name=run.sh -Xms128m -Xmx512m -XX:MaxPermSize=256m -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true -Djava.endorsed.dirs=/opt/jboss-5.1.0.GA/lib/endorsed
      16:06:38,661 INFO  [JMXKernel] Legacy JMX core initialized
      16:07:24,962 INFO  [ProfileServiceBootstrap] Loading profile: ProfileKey@15837e8[domain=default, server=default, name=default]
      16:07:38,479 INFO  [WebService] Using RMI server codebase: http://127.0.0.1:8083/
      16:08:12,525 INFO  [NativeServerConfig] JBoss Web Services - Stack Native Core
      16:08:12,526 INFO  [NativeServerConfig] 3.1.2.GA
      16:08:15,355 INFO  [AttributeCallbackItem] Owner callback not implemented.
      16:09:21,858 INFO  [LogNotificationListener] Adding notification listener for logging mbean "jboss.system:service=Logging,type=Log4jService" to server org.jboss.mx.server.MBeanServerImpl@cb754f[ defaultDomain='jboss' ]
      run.sh: line 305:  8098 Killed                  "$JAVA" $JAVA_OPTS -Djava.endorsed.dirs="$JBOSS_ENDORSED_DIRS" -classpath "$JBOSS_CLASSPATH" org.jboss.Main "$@"

        • 1. Re: Not able to start the Jboss server
          Peter Johnson Master

          All I see are INFO messages; where is the problem?

           

          Since you will not tell us what the problem is, let me make a guess: are you saying that the console log stops at this point and there is no more output? If that is what you mean, then I suspect that someone truned off the console log in server/default/conf/jboss-log4j.xml.  The logging that you are seeing is the bootstrap logging, which is handled by a different logging configuration file. Once bootstrap is completed it hands the proicess over to the app server whose logging is defined in the jboss-log4j.xml file. If the CONSOLE log is disabled in that file, the result is what you are experiencing. You can either re-anable the CONSOLE log or check the server.log to monitor the rest of the startup. Most likely, you can access the app server home page at http://localhost:8080

          • 2. Re: Not able to start the Jboss server
            Rajyalakshmi Domathoti Newbie

            Thanks for your response.

             

            Let me explain clearly .

            When i start the server, with run.sh script, my console stop at the middle.

            And  i am not able to access the http://localhost:8080 ---showing unable to connect

             

            Please have a look at the server.log and jboss-log4j.xml files attached.

             

            server.log

            ==================

             

            2010-07-02 09:42:59,499 INFO  [org.jboss.web.WebService] (main) Using RMI server codebase: http://127.0.0.1:8083/
            2010-07-02 09:43:55,855 INFO  [org.jboss.wsf.stack.jbws.NativeServerConfig] (main) JBoss Web Services - Stack Native Core
            2010-07-02 09:43:55,885 INFO  [org.jboss.wsf.stack.jbws.NativeServerConfig] (main) 3.1.2.GA
            2010-07-02 09:44:10,534 INFO  [org.jboss.dependency.plugins.AttributeCallbackItem] (main) Owner callback not implemented.
            ~                                                                                                                                           
            ~               

             

            Thanks, Rajyalakshmi

            • 3. Re: Not able to start the Jboss server
              Peter Johnson Master

              Once again, these are INFO messages and I still have no clue regarding the problem you are seeing.

               

              In your post, when you list the server.log, you end it with two tildes (~) which to me implies that there are more server.log entries. Yet the log file you appended has only the four lines in your post. Is that all of it? Or is there more?

              • 4. Re: Not able to start the Jboss server
                Peter Johnson Master

                Wait a minute, I did not see this line in the console output that you posted earlier (I thought it was part of the part INFO log message and never even looked at it):

                 

                run.sh: line 305:  8098 Killed                  "$JAVA" $JAVA_OPTS  -Djava.endorsed.dirs="$JBOSS_ENDORSED_DIRS" -classpath  "$JBOSS_CLASSPATH" org.jboss.Main "$@"

                 

                Have you made any changes to run.sh? I ask because of the line number - the command on that line doesn't made sense given this output. Also, how are you srating JBoss AS?  Also, are you setting LAUNCH_JBOSS_IN_BACKGROUND?

                • 5. Re: Not able to start the Jboss server
                  Rajyalakshmi Domathoti Newbie

                  Hi Peter,

                  Sorry for the late reply.Today only i came back to office,.

                  I am getting the server log that much only. ~ is the end of file.

                  Coming to run.sh line 305, i sent you the other run.sh file .Now i am attaching the corrct file.

                  Actually it is showing the last line of the script.

                  • 6. Re: Not able to start the Jboss server
                    Rajyalakshmi Domathoti Newbie

                    We solved this issue.

                    the issue is with memory.When we install Jboss5  in VM of 256MB , it is killed in the middle.If we use Jboss4 , it is working fine.

                    we checked installing Jboss5 version in 1GB machine, server started successfully.