4 Replies Latest reply on Jul 9, 2010 3:36 AM by Marko Asplund

    BEA WebLogic to JBoss 5 migration problem

    Marko Asplund Newbie

      Hi,

       

      I'm working on a customer project where we're studying the feasibility

      of migrating the customer's applications from BEA WebLogic Server v8.1 to JBoss AS 5 (5.0 or 5.1).

      They have a distributed system that consists of multiple applications running

      on a number of application server instances. The applications mostly use SLSB EJB

      calls to communicate but Web Services and JMS are used as well.

       

      I did some testing with the EJB call interoperability between WLS 8 and JBoss 5

      and ran into problems. I've deployed a J2EE v1.4 SLSB EJB on both servers.

      The EJB callout from JBoss to WLS works fine but unfortunately it doesn't

      work from WLS to JBoss. This is because WLS 8 uses Java 1.4 while JBoss 5 runs on Java 1.5.

      The JBoss 5 (and 4.2) EJB client jars are compiled with Java 1.5 so these can't be used with WLS.

      JBoss 4.0 EJB client jars don't seem to work with JBoss AS 5 due to dependencies on Java 1.5.

       

      Since the applications can't be migrated all at once in practice, it would be necessary

      to be able to run both application servers in parallel for some period of time.

       

      Is there a way to make EJB call-outs from Java 1.4 / WLS 8 to JBoss AS 5?

        • 1. Re: BEA WebLogic to JBoss 5 migration problem
          jaikiran pai Master

          Marko Asplund wrote:

           


          of migrating the customer's applications from BEA WebLogic Server v8.1 to JBoss AS 5 (5.0 or 5.1).

          I would recommend the latest 5.1.0 (and not 5.0). There have been numerous bug fixes since 5.0.

           

          Marko Asplund wrote:

           


          JBoss 4.0 EJB client jars don't seem to work with JBoss AS 5

           

          That's correct.

           

          Marko Asplund wrote:

           

          I've deployed a J2EE v1.4 SLSB EJB on both servers.

          The EJB callout from JBoss to WLS works fine but unfortunately it doesn't

          work from WLS to JBoss. This is because WLS 8 uses Java 1.4 while JBoss 5 runs on Java 1.5.

          The JBoss 5 (and 4.2) EJB client jars are compiled with Java 1.5 so these can't be used with WLS.

           

           

          Since the applications can't be migrated all at once in practice, it would be necessary

          to be able to run both application servers in parallel for some period of time.

           

          Is there a way to make EJB call-outs from Java 1.4 / WLS 8 to JBoss AS 5?

           

          Why not just run the WLS against Java 1.5 runtime? Since Java 1.5 is backward compatible, your Java 1.4 application should ideally run fine in a JRE 1.5 runtime. Ofcourse, if this is something in production, then I can understand that upgrading software (or even hardware) isn't easily approved. But I can't think of any other way around this.

          1 of 1 people found this helpful
          • 2. Re: BEA WebLogic to JBoss 5 migration problem
            Marko Asplund Newbie

            Hi,

             

            WLS v8.1 is only supported with Java 1.4 so I don't think we can upgrade the Java version for the existing installations.

             

            From an application developer perspective it feels a bit odd that I can't call JBoss 5 EJBs from Java 1.4.

            I realize Java 1.4 is extremely old but unfortunately there're still a lot of applications that are being run with it.

            I just tested EJB interoperability between WLS versions 8 (Java 1.4) and 10 (Java 1.6), and they didn't

            have any problems talking to each other.

             

            Since a phased migration is essential and if we can't do that with JBoss,

            we'll probably have to consider migrating to newer WLS version instead.

            • 3. Re: BEA WebLogic to JBoss 5 migration problem
              David Lloyd Master

              Marko Asplund wrote:

               

              From an application developer perspective it feels a bit odd that I can't call JBoss 5 EJBs from Java 1.4.

              I realize Java 1.4 is extremely old but unfortunately there're still a lot of applications that are being run with it.

              I just tested EJB interoperability between WLS versions 8 (Java 1.4) and 10 (Java 1.6), and they didn't

              have any problems talking to each other.


              It should work if you use IIOP.

              • 4. Re: BEA WebLogic to JBoss 5 migration problem
                Marko Asplund Newbie

                How do I configure JBoss to use IIOP?

                Apparently the "default" server configuration supports IIOP but what about the client side?

                Which context factory implementation class should be used with IIOP?

                What about the URL format? iiop://<host_address>:<host_port>?

                What's the default port for IIOP in JBoss?