0 Replies Latest reply on Jul 8, 2010 5:42 AM by Nikolay Elenkov

    error calling InternetResourceBase.getUri()

    Nikolay Elenkov Newbie

      Hi,

       

      I'm using RF 3.3.1.GA with Seam 2.2.1 on JBoss 5.1. In one of my views I have the following code to display the proper icon in a rich:dataTable column (for custom sorting):

       

       

      {code:xml}<h:graphicImage  value="#{mycomponent.getSortIconUrl('column1')}"/>{code}

       

      This calls a the backing bean, which in turns calls a utility class with the following code:

       

      {code}public static String getResourceUri(String clazz) {

               InternetResourceBuilder builder = ResourceBuilderImpl.getInstance();


               builder.createResource(null, clazz);


              InternetResource  resource = builder.getResource(clazz);


               FacesContext fc = FacesContext.getCurrentInstance();


               HttpServletRequest httpRequest = (HttpServletRequest) fc.getExternalContext().getRequest();


              String  scheme = httpRequest.getScheme();

              String uri =  resource.getUri(fc, null);

       


              return scheme + ":" +  uri;

          }{code}

       

       

      This all used to work fine with RF 3.2.2, but now I'm getting the following exception:

       

      {code}

      IllegalStateException: Application was not properly initialized  at startup, could not find Factory:  javax.faces.application.ApplicationFactory
           at  javax.faces.FactoryFinder$FactoryManager.getFactory(FactoryFinder.java:725)     at javax.faces.FactoryFinder.getFactory(FactoryFinder.java:239)
           at  org.richfaces.skin.SkinFactoryImpl.processProperties(SkinFactoryImpl.java:239)
           at  org.richfaces.skin.SkinFactoryImpl.buildSkin(SkinFactoryImpl.java:278)
           at  org.richfaces.skin.SkinFactoryImpl.getSkinByName(SkinFactoryImpl.java:133)
           at org.richfaces.skin.SkinFactoryImpl.getSkin(SkinFactoryImpl.java:150)
           at  org.richfaces.renderkit.html.images.TriangleIconBase.getDataToStore(TriangleIconBase.java:142)
           at  org.richfaces.renderkit.html.images.TriangleIconBase.getDataToStore(TriangleIconBase.java:104)
           at  org.ajax4jsf.resource.InternetResourceBase.getUri(InternetResourceBase.java:218)
      {code}

       

       

      If I remove the <graphicImage/> tags from my xhtml file, everyting else works fine, so I'm assuing that Facelets/JSF/RF is configured properly.

       

      Any ideas as to what is going wrong?