5 Replies Latest reply on Jul 12, 2011 2:58 PM by joe_boy12

    Wise Consumer SOA-P sample/quickstarts not working...

    a_jb_user _ Newbie

      The WARN below is the last thing in the log.  It never gets to the Wise SOAPClient.  The same thing happens with Wise 1-4 quickstarts.

       

      Is this is a known/common problem, is there a known solution?  If not, can anyone recommend next steps to debug, or other resources?

       

      2010-07-14 21:36:44,550 INFO  [STDOUT] (pool-28-thread-1) &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
      2010-07-14 21:36:44,550 INFO  [STDOUT] (pool-28-thread-1) Request map is: {toWhom=Jimbo}
      2010-07-14 21:36:44,550 INFO  [STDOUT] (pool-28-thread-1) &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
      2010-07-14 21:36:44,581 WARN  [org.jboss.soa.esb.listeners.message.ActionProcessingPipeline] (pool-28-thread-1) No fault address defined for fault message! To: JMSEpr [ PortReference < <wsa:Address jms:localhost#queue/quickstart_webservice_consumer_wise_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.url.pkgs : org.jnp.interfaces/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:destination-name : queue/quickstart_webservice_consumer_wise_esb/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : AUTO_ACKNOWLEDGE/>, <wsa:ReferenceProperties jbossesb:transacted : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] MessageID: 5ec0c22e-5845-42e9-a2d1-c6c91a0ab482 RelatesTo: jms:correlationID#5ec0c22e-5845-42e9-a2d1-c6c91a0ab482

        • 1. Re: Wise Consumer SOA-P sample/quickstarts not working...
          a_jb_user _ Newbie

          This is with version:

          JBoss SOA Platform: Embedded Server - Version 5.0.1.GA

          • 2. Re: Wise Consumer SOA-P sample/quickstarts not working...
            Kevin Conner Master

            Can you enable DEBUG and see what the underlying exception is?

             

            Kev

            • 3. Re: Wise Consumer SOA-P sample/quickstarts not working...
              a_jb_user _ Newbie

              Thanks, that helps.

               

              Is the cause of this a missing backslash?

              Caused by: java.io.FileNotFoundException: C:Temp\Wise0.xml (The system cannot find the path specified)

               

              FYI, I'm using Windows 7.

               

              Log:

              2010-07-16 10:06:29,158 INFO  [STDOUT] (pool-28-thread-1) &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
              2010-07-16 10:06:29,158 INFO  [STDOUT] (pool-28-thread-1) Request map is: {toWhom=Jimbo}
              2010-07-16 10:06:29,174 INFO  [STDOUT] (pool-28-thread-1) &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
              2010-07-16 10:06:29,174 DEBUG [org.jboss.soa.esb.listeners.message.ActionProcessingPipeline] (pool-28-thread-1) executing processor 1 Wise SOAPClient [wsdl=http://127.0.0.1:8080/Quickstart_webservice_consumer_wise/HelloWorldWS?wsdl, soapAction=sayHello, endPointName=HelloWorldPort, serviceName=HelloWorldWS, smooksRequestMapperURL=null, smooksResponseMapperURL=null]
              2010-07-16 10:06:29,330 DEBUG [org.jboss.wsf.framework.DefaultSPIProvider] (http-127.0.0.1-8080-1) provide SPI 'class org.jboss.wsf.spi.management.EndpointRegistryFactory'
              2010-07-16 10:06:29,346 DEBUG [org.jboss.wsf.framework.DefaultSPIProvider] (http-127.0.0.1-8080-1) class org.jboss.wsf.spi.management.EndpointRegistryFactory Implementation: org.jboss.wsf.stack.jbws.EndpointRegistryFactoryImpl@58be937b
              2010-07-16 10:06:29,361 DEBUG [org.jboss.wsf.stack.jbws.RequestHandlerImpl] (http-127.0.0.1-8080-1) handleWSDLRequest: jboss.ws:context=Quickstart_webservice_consumer_wise,endpoint=HelloWorldWS
              2010-07-16 10:06:29,361 DEBUG [org.jboss.wsf.stack.jbws.RequestHandlerImpl] (http-127.0.0.1-8080-1) WSDL request, using host: 127.0.0.1
              2010-07-16 10:06:29,377 DEBUG [org.jboss.soa.esb.listeners.message.ActionProcessingPipeline] (pool-28-thread-1) Unexpected exception caught while processing the action pipeline
              org.jboss.soa.esb.actions.ActionProcessingException: Wsdl download failed!
              at org.jboss.soa.esb.actions.soap.wise.SOAPClient.createClient(SOAPClient.java:281)
              at org.jboss.soa.esb.actions.soap.wise.SOAPClient.process(SOAPClient.java:238)
              at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:634)
              at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:588)
              at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.process(ActionProcessingPipeline.java:419)
              at org.jboss.soa.esb.listeners.message.MessageAwareListener$TransactionalRunner.run(MessageAwareListener.java:540)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
              at java.lang.Thread.run(Thread.java:619)
              Caused by: it.javalinux.wise.core.exceptions.WiseConnectionException: Wsdl download failed!
              at org.jboss.soa.esb.actions.soap.wise.WSDynamicClientFactory.transferWSDL(WSDynamicClientFactory.java:144)
              at org.jboss.soa.esb.actions.soap.wise.WSDynamicClientFactory.downloadWsdl(WSDynamicClientFactory.java:80)
              at org.jboss.soa.esb.actions.soap.wise.WSDynamicClientFactory.create(WSDynamicClientFactory.java:68)
              at org.jboss.soa.esb.actions.soap.wise.SOAPClient.createClient(SOAPClient.java:277)
              ... 8 more
              Caused by: java.io.FileNotFoundException: C:Temp\Wise0.xml (The system cannot find the path specified)
              at java.io.FileOutputStream.open(Native Method)
              at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
              at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
              at org.jboss.soa.esb.actions.soap.wise.WSDynamicClientFactory.transferWSDL(WSDynamicClientFactory.java:132)
              ... 11 more
              2010-07-16 10:06:29,392 WARN  [org.jboss.soa.esb.listeners.message.ActionProcessingPipeline] (pool-28-thread-1) No fault address defined for fault message! To: JMSEpr [ PortReference < <wsa:Address jms:localhost#queue/quickstart_webservice_consumer_wise_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.url.pkgs : org.jnp.interfaces/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:destination-name : queue/quickstart_webservice_consumer_wise_esb/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : AUTO_ACKNOWLEDGE/>, <wsa:ReferenceProperties jbossesb:transacted : false/>, <wsa:R
              • 4. Re: Wise Consumer SOA-P sample/quickstarts not working...
                Daniel Bevenius Master

                What is the 'wise.tmpDir' property in wise-core.properties set to? (you can find this file in the wise quickstart directory)

                 

                Regards,

                 

                /Daniel

                • 5. Re: Wise Consumer SOA-P sample/quickstarts not working...
                  joe_boy12 Novice

                  have you guys figured that out? I am having same issue. it works if I give absolute path there e.g. c:/jboss-as/server/esb/tmp