3 Replies Latest reply on Oct 2, 2010 8:15 AM by jaikiran pai

    Classloader issue JBoss AS 6.0 M5

    Elias Ross Master

      I have a third-party library I'm trying to load under AS 6.0M5, the library is obfuscated and causing trouble when loading itself. (It's a free download from https://www.objectxp.com/merchant/download.do ) The message:

       

      12:12:23,112 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/llgateway]] Servlet /llgateway threw load() exception: java.lang.NoClassDefFoundError: com/objectxp/msg/t (wrong name: com/objectxp/msg/T)
              at java.lang.ClassLoader.defineClass1(Native Method) [:1.6.0_21]
              at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632) [:1.6.0_21]
              at java.lang.ClassLoader.defineClass(ClassLoader.java:616) [:1.6.0_21]
              at org.jboss.classloader.spi.base.BaseClassLoader.access$200(BaseClassLoader.java:52) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseClassLoader$2.run(BaseClassLoader.java:650) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseClassLoader$2.run(BaseClassLoader.java:609) [jboss-classloader.jar:2.2.0.Alpha8]
              at java.security.AccessController.doPrivileged(Native Method) [:1.6.0_21]
              at org.jboss.classloader.spi.base.BaseClassLoader.loadClassLocally(BaseClassLoader.java:608) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseClassLoader.loadClassLocally(BaseClassLoader.java:585) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseDelegateLoader.loadClass(BaseDelegateLoader.java:156) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.filter.FilteredDelegateLoader.doLoadClass(FilteredDelegateLoader.java:141) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.filter.FilteredDelegateLoader.loadClass(FilteredDelegateLoader.java:132) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.ClassLoadingTask$ThreadTask.run(ClassLoadingTask.java:461) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.ClassLoaderManager.nextTask(ClassLoaderManager.java:262) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.ClassLoaderManager.process(ClassLoaderManager.java:161) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseClassLoaderDomain.loadClass(BaseClassLoaderDomain.java:260) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseClassLoaderDomain.loadClass(BaseClassLoaderDomain.java:1152) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseClassLoader.loadClassFromDomain(BaseClassLoader.java:886) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseClassLoader.doLoadClass(BaseClassLoader.java:505) [jboss-classloader.jar:2.2.0.Alpha8]
              at org.jboss.classloader.spi.base.BaseClassLoader.loadClass(BaseClassLoader.java:450) [jboss-classloader.jar:2.2.0.Alpha8]
              at java.lang.ClassLoader.loadClass(ClassLoader.java:248) [:1.6.0_21]
              at java.lang.Class.forName0(Native Method) [:1.6.0_21]
              at java.lang.Class.forName(Class.java:169) [:1.6.0_21]
              at com.autodesk.lbs.sms.jsms.JSMSAdapter.startService(JSMSAdapter.java:139) [:1.0.0.16]

       

      The .jar has these contents:

       

      $ unzip -l jSMS-2.2.3.jar  | grep /[tT].class
            773  11-05-2008 06:56   com/objectxp/mms/protocol/A/T.class
           2956  11-05-2008 06:56   com/objectxp/msg/T.class
            244  11-05-2008 06:56   com/objectxp/msg/t.class
      

       

      Is this a bug? I'm not sure who/how to report this.