5 Replies Latest reply on Dec 6, 2010 12:02 AM by swetha sundar

    richfaces with andromda...

    swetha sundar Newbie

      My application which uses AndroMDA 3.3 + Richfaces 3.1.4.GA + JSF 1.2 works well. But I am unable to use various advanced features of the latest version of RichFaces.I have hence planned to upgrade the Richfaces version to make full use of it. I prefer to use Richfaces 3.3.1.GA and have added the jars to  the web-inf/lib.

       

      As a result, i get unsupported operation exception in javax.faces.context.FacesContext.getELContext.

       

      I believe its because of jar mismatch....

       

      currently my web-inf/lib consists of the following jars:

       

      tomahawk.jar
      standard-1.1.1.jar
      richfaces-ui-3.3.1.GA.jar
      richfaces-api-3.3.1.GA.jar
      richfaces-impl-3.3.1.GA.jar
      oro-2.0.8.jar
      adf-faces-impl.jar
      adf-faces-api.jar
      commons-el-1.0.jar
      jstl-1.1.2.jar
      itext-0.99.jar
      commons-validator-1.1.4
      commons-el-1.0
      commons-discovery-0.4
      commons-digester-1.7
      andromda-utils-3.3
      andromda-jsf-cartridge-components
      commons-beanutils-1.7.0.jar
      commons-fileupload-1.1.1.jar
      commons-logging-1.1.jar

      jsf1.2.jar

      myfaces 1.1.5.jar

       

      Could u please tell the other jars( including jsf ) that i will have to upgrade to make them compatible with Richfaces 3.3.1.GA??????? herewith i have attached the web/pom.xml.