0 Replies Latest reply on Dec 10, 2010 6:01 AM by j4nu5

    MyFaces 2.0.1 + Rich Faces 3.3.3 -> No Rendering

    j4nu5 Newbie

      Hi!

       

      I want to integrate RichFaces into my MyFaces Project. I followed the guide in the wiki (http://community.jboss.org/wiki/RichFaces333andJSF20)

      and changed my web.xml and faces-config accordingly.

       

      Output of the Page:

       

      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml"
            xmlns:h="http://java.sun.com/jsf/html"
            xmlns:f="http://java.sun.com/jsf/core"
            xmlns:ui="http://java.sun.com/jsf/facelets">

      <head><link class="component" href="/Feedback/a4j/s/3_3_3.Finalorg/richfaces/renderkit/html/css/basic_classes.xcss/DATB/eAELXT5DOhSIAQ!sA18_.jsf" rel="stylesheet" type="text/css" /><link class="component" href="/Feedback/a4j/s/3_3_3.Finalorg/richfaces/renderkit/html/css/extended_classes.xcss/DATB/eAELXT5DOhSIAQ!sA18_.jsf" media="rich-extended-skinning" rel="stylesheet" type="text/css" /><script type="text/javascript">window.RICH_FACES_EXTENDED_SKINNING_ON=true;</script><script src="/Feedback/a4j/g/3_3_3.Finalorg/richfaces/renderkit/html/scripts/skinning.js.jsf" type="text/javascript"></script></head><body>
      <ui:composition template="../template.xhtml">
          <ui:define name="content">
                 Some text...
          </ui:define>

        </ui:composition>
      </body>

      </html>

       

      My web.xml:

       

      <servlet>
              <servlet-name>Faces Config</servlet-name>
              <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
              <load-on-startup>1</load-on-startup>
          </servlet>
          <servlet-mapping>
              <servlet-name>Faces Config</servlet-name>
              <url-pattern>*.jsf</url-pattern>
          </servlet-mapping>
         
          <context-param>
               <param-name>javax.faces.DISABLE_FACELET_JSF_VIEWHANDLER</param-name>
               <param-value>true</param-value>
          </context-param>
         
         <context-param>
             <param-name>org.ajax4jsf.VIEW_HANDLERS</param-name>
             <param-value>com.sun.facelets.FaceletViewHandler</param-value>
         </context-param>
        
            <!-- Defining and mapping the RichFaces filter -->
         <filter>
            <display-name>RichFaces Filter</display-name>
            <filter-name>richfaces</filter-name>
            <filter-class>org.ajax4jsf.Filter</filter-class>
         </filter>
         <filter-mapping>
            <filter-name>richfaces</filter-name>
            <servlet-name>Faces Config</servlet-name>
            <dispatcher>REQUEST</dispatcher>
            <dispatcher>FORWARD</dispatcher>
            <dispatcher>INCLUDE</dispatcher>
         </filter-mapping>

      </web-app>

       

      My Faces-config

      <application>

           <view-handler>org.ajax4jsf.application.AjaxViewHandler</view-handler>
      </application>

       

      I added the following libs among others:

      richfaces-api-3.3.3.Final

      richfaces-impl-jsf2-3.3.3.Final

      richfaces-ui-3.3.3.Final

      myfaces-api-2.0.1

      myfaces-impl-2.0.1

       

      Adding jsf-facelets-1.1.15 results in a 404.

      Im using Facelets as View.

       

      Any Idea!?

       

      Thanks for your help!