1 Reply Latest reply on Apr 20, 2011 7:52 AM by Prasad Deshpande

    java.util.Locale does not have a no-arg default constructor

    Prasad Deshpande Expert

      Hi,

       

      Firstly, my issue is related with jboss & CXF but i'm not using inbuild cxf support in jboss. I have an ear in which I've deployed a webservice as war file using CXF's spring deployment.

       

      Packaging works fine on jboss 5.1.0.GA released version. I've then checked-out jboss 5.1.0 from SVN & using it. But the same war doesn't deploy with this checked-out version. It gives me error.

       

      Caused by: com.sun.xml.bind.v2.runtime.IllegalAnnotationsException: 1 counts of IllegalAnnotationExceptions java.util.Locale does not have a no-arg default constructor.

          this problem is related to the following location:

              at java.util.Locale

              at private java.util.Locale com.client.api.wsapi.jaxws_asm.Translate.arg1

              at com.client.api.wsapi.jaxws_asm.Translate

       

          at com.sun.xml.bind.v2.runtime.IllegalAnnotationsException$Builder.check(IllegalAnnotationsException.java:102)

          at com.sun.xml.bind.v2.runtime.JAXBContextImpl.getTypeInfoSet(JAXBContextImpl.java:472)

          at com.sun.xml.bind.v2.runtime.JAXBContextImpl.<init>(JAXBContextImpl.java:302)

          at com.sun.xml.bind.v2.runtime.JAXBContextImpl$JAXBContextBuilder.build(JAXBContextImpl.java:1136)

          at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:154)

          at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:121)

          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

          at java.lang.reflect.Method.invoke(Method.java:597)

          at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:202)

          at javax.xml.bind.ContextFinder.find(ContextFinder.java:363)

          at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:574)

          at org.apache.cxf.jaxb.JAXBDataBinding.createContext(JAXBDataBinding.java:557)

          at org.apache.cxf.jaxb.JAXBDataBinding.createJAXBContextAndSchemas(JAXBDataBinding.java:497)

          at org.apache.cxf.jaxb.JAXBDataBinding.initialize(JAXBDataBinding.java:324)

          ... 105 more

       

      Do you think it could be because of classloading issue or any or jar file has changed/updated in SVN after 5.1.0.GA is released? I suspect XmlSchema.jar. Also the version I'm using of CXF is 2.2.6 if that helps.