4 Replies Latest reply on Mar 15, 2011 10:46 AM by Mason Clear

    Webservice call still gets SSL Factory error - after all is setup

    Mason Clear Newbie

      First I want to apologize if I am placing this in the wrong forum.

       

      Now to outline the task.... I have a long running transaction that is scheduled via Quartz. Within the transaction it will make a call to a soap service under SSL, provided by our HR system Workday. The all returns a list of employees, then the transaction will make DB calls.

       

      The issue.. . .  during the WSDL calls, I get the following error

      Error creating SSl Socket Factory for client invoker: Error initializing socket factory SSl context: Can non find truststore url.

       

      What I have done to correct this. I have setup SSL for JBOSS in the jbossweb.sar/server.xml. Along with that I have setup the JAVA_OPTs in the run.conf.bat file. For the SSL settings I have done both keystore and truststore.

       

      No matter what I still get this error .  ..

      Oddly, if I run the code in just Eclipse (as a java application) the code has no issues and gets know ssl errors.

       

       

      Thoughts on what I am missing.. . .

       

      Environment

      JBoss 5.1 (both jdk5 and jdk6 have been tested)
      Java 1.6.0_24

      Windows 7 32 bit

        • 1. Webservice call still gets SSL Factory error - after all is setup
          Mason Clear Newbie

          I still cant seem to get this error message to go away. I have completely redone my JBoss setup and double checked everything. I have SSL support on port 8443. I am able to make SSL calls to an ActiveDirectory server with no errors reported. I am also able to make standard HTTPS SSL calls using httpComponents. I even have two webservice endpoints under jbossWS, both of which are SSL only, and they work. I am only getting SSL errors when calling someone elses Web Service.

          • 2. Webservice call still gets SSL Factory error - after all is setup
            Mason Clear Newbie

            I am getting closer. I am now able to make webservice calls without the warning/error . But its very strange how I got it to work. Removing the settings from jbossweb /server.xml and leaving the settings in run.conf.bat made the errors go away. For some reason I still get the errors if I have the settings in the XML file, although I get no errors on startup and HTTPS:8443 works fine.

             

            Crazy...

            • 3. Webservice call still gets SSL Factory error - after all is setup
              Mason Clear Newbie

              I jumped the gun on this one. The error is still there.

              • 4. Webservice call still gets SSL Factory error - after all is setup
                Mason Clear Newbie

                I am missing something, but I cant figure it out. I understand that this issue seems to have been covered a few times, but everything everyone says as being a solution is something I have already done before I even looked for a solution. I must be looking over some small detail..... below is what Iv done (for the 100th time in a row). Yet still have the error, although I have full SSL support.

                 

                Please note that the * is just to cover the real values.

                 

                keytool -genkey -alias jboss -keyalg RSA -dname "CN=localhost,OU=*,O=*,L=*,S=*,C=US" -keystore .keystore

                 

                keytool -export -alias jboss -file jboss.cer

                 

                keytool -import -alias jboss -keystore .truststore -file jboss.cer

                 

                 

                 

                jboss-5.1.0.GA-jdk6\bin\run.conf.bat

                set "JAVA_OPTS=%JAVA_OPTS% -Djava.net.ssl.keyStore=%JBOSS_HOME%/server/default/conf/.keystore"

                set "JAVA_OPTS=%JAVA_OPTS% -Djava.net.ssl.keyStorePassword=*"

                set "JAVA_OPTS=%JAVA_OPTS% -Djava.net.ssl.trustStore=%JBOSS_HOME%/server/default/conf/.truststore"

                set "JAVA_OPTS=%JAVA_OPTS% -Djava.net.ssl.trustStorePassword=*"

                 

                 

                 

                jboss-5.1.0.GA-jdk6\server\default\deploy\jbossweb.sar\server.xml

                      <Connector protocol="HTTP/1.1" SSLEnabled="true"

                           port="8443" address="${jboss.bind.address}"

                           scheme="https" secure="true" clientAuth="true"

                           keystoreFile="${jboss.server.home.dir}/conf/.keystore" keystorePass="*"

                           truststoreFile="${jboss.server.home.dir}/conf/.truststore" truststorePass="*"

                           sslProtocol = "TLS" />