10 Replies Latest reply on Mar 8, 2012 8:56 AM by matthiasr

    JBOSS ESB HelloWorld QuickStart Sample Issue

    jass Newbie

      Hello All,

       

      I am fairly new to JBOSS And JBOSS-ESB.

       

      I downloaded and deployed JBOSS-AS and JBOSS-ESB seperately as well as JBOSS-ESB-SERVER, Both ways I am unable to run the 1st QuikStart Hello-World sample (I am using Windows-XP).

       

      When I use JBOSS-ESB-SERVER (Version-4.9)

      ===================================

       

      When running "ant deploy", following is the error thrown in the Server Console; So, I am unable to move to "ant runtest".

       

       

      17:23:48,765 INFO  [Http11Protocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8

      080

      17:23:48,796 INFO  [AjpProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009

      17:23:48,859 INFO  [Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBos

      s_4_2_3_GA date=200807181417)] Started in 2m:28s:672ms

      17:26:34,125 INFO  [QueueService] Queue[/queue/quickstart_helloworld_Request_gw]

      stopped

      17:26:34,125 INFO  [QueueService] Queue[/queue/quickstart_helloworld_Request_esb

      ] stopped

      17:26:34,218 INFO  [JBoss4ESBDeployer] create esb service, Quickstart_helloworld

      .esb

      17:26:34,234 INFO  [QueueService] Queue[/queue/quickstart_helloworld_Request_esb

      ] started, fullSize=200000, pageSize=2000, downCacheSize=2000

      17:26:34,234 INFO  [QueueService] Queue[/queue/quickstart_helloworld_Request_gw]

      started, fullSize=200000, pageSize=2000, downCacheSize=2000

      17:26:34,250 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

       

      --- MBeans waiting for other MBeans ---

      ObjectName: jboss.esb:service=JuddiRMI

        State: FAILED

        Reason: java.lang.ExceptionInInitializerError

        I Depend On:

          jboss.esb:service=JUDDIDatabaseInitializer

          jboss.esb:service=PropertyService

        Depends On Me:

          jboss.esb:service=JuddiClient

       

      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---

      ObjectName: jboss.esb:service=JuddiRMI

        State: FAILED

        Reason: java.lang.ExceptionInInitializerError

        I Depend On:

          jboss.esb:service=JUDDIDatabaseInitializer

          jboss.esb:service=PropertyService

        Depends On Me:

          jboss.esb:service=JuddiClient

       

      When running JBOSS-AS (Version 6.0.0, Esb-Version - JBOSS-ESB-4.9)

      ======================================================

       

      I am able successfully deplot the service using "ant deploy", but when running "ant runtest" on the simple HelooWorld is fails with the following Errors on the Windows Console -

       

      compile:

          [javac] C:\JBoss-ESB\jbossesb-4.9\samples\quickstarts\conf\base-build.xml:43

      5: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=la

      st; set to false for repeatable builds

          [javac] C:\JBoss-ESB\jbossesb-4.9\samples\quickstarts\conf\base-build.xml:44

      0: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=la

      st; set to false for repeatable builds

       

      runtest:

           [echo] Runs Test JMS Sender

           [java] log4j:ERROR Could not instantiate class [org.jboss.logging.util.Only

      OnceErrorHandler].

           [java] java.lang.ClassNotFoundException: org.jboss.logging.util.OnlyOnceErr

      orHandler

           [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:202)

           [java]     at java.security.AccessController.doPrivileged(Native Method)

           [java]     at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

           [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:307)

       

      I feel there are some serious config issues, but I am fairly new to ESB and JBOSS config, Can some body provide expert comments?

       

      Thanks.