2 Replies Latest reply on May 18, 2011 8:28 PM by Rosh Margappa

    Installation issues with 6.0

    Rosh Margappa Newbie

      Can someone help?

       

      I get this when I run.sh:

       

      # ./run.sh

      =========================================================================

       

       

        JBoss Bootstrap Environment

       

       

        JBOSS_HOME: /usr/jboss/jboss-6.0.0.Final

       

       

        JAVA: java

       

       

        JAVA_OPTS: -server -Xms128m -Xmx512m -XX:MaxPermSize=256m -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true -Dprogram.name=run.sh -Djava.library.path=/usr/jboss/jboss-6.0.0.Final/bin/native/lib64

       

       

        CLASSPATH: /usr/jboss/jboss-6.0.0.Final/bin/run.jar

       

       

      =========================================================================

       

       

      Exception in thread "main" java.lang.NoClassDefFoundError: org/jboss/logmanager/Logger$AttachmentKey

                at org.jboss.logging.JBossLogManagerProvider.<clinit>(JBossLogManagerProvider.java:36)

                at org.jboss.logging.LoggerProviders.findProvider(LoggerProviders.java:33)

                at org.jboss.logging.LoggerProviders.<clinit>(LoggerProviders.java:28)

                at org.jboss.logging.Logger.getLogger(Logger.java:2164)

                at org.jboss.logging.Logger.getLogger(Logger.java:2189)

                at org.jboss.bootstrap.impl.base.server.AbstractServer.<clinit>(AbstractServer.java:69)

                at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

                at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)

                at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)

                at java.lang.reflect.Constructor.newInstance(Constructor.java:532)

                at java.lang.Class.newInstance0(Class.java:372)

                at java.lang.Class.newInstance(Class.java:325)

                at org.jboss.bootstrap.api.factory.SecurityActions$1.run(SecurityActions.java:95)

                at java.security.AccessController.doPrivileged(Native Method)

                at org.jboss.bootstrap.api.factory.SecurityActions.newInstance(SecurityActions.java:75)

                at org.jboss.bootstrap.api.factory.GenericFactory.createInstance(GenericFactory.java:97)

                at org.jboss.bootstrap.api.factory.ServerFactory.createServer(ServerFactory.java:84)

                at org.jboss.Main.boot(Main.java:439)

                at org.jboss.Main$1.run(Main.java:805)

                at java.lang.Thread.run(Thread.java:636)

       

      My JDK seems to be fine:

      #

      # java -version

      java version "1.6.0_20"

      OpenJDK Runtime Environment (IcedTea6 1.9.1) (fedora-44.1.9.1.fc14-x86_64)

      OpenJDK 64-Bit Server VM (build 19.0-b06, mixed mode)

      # which java

      /usr/bin/java