4 Replies Latest reply on Jul 14, 2011 6:51 PM by Fred Bricon

    Problem with Plugin JBoss Maven CDI Configurator 3.3 M2

    Gonne Martens Novice

      Hi,

       

      I am using Eclipse 3.7 with M2E Maven Integration and JBoss Tools 3.3 M2.

      When I try to update the project configuration (Menu Maven -> Update project configuration) for a simple maven EJB project with a CDI dependency (javax.enterprise:cdi-api:1.0-SP4) I get the following error message:

       

      Errors occurred during the build.

      Errors running builder 'Maven Project Builder' on project 'sandbox-ejb'.

      Cannot compare versions of different facets to each other. Attempted to compare version 3.1 of facet jst.ejb with version 2.5 of facet jst.web.

       

      I tried to isolate the problem by removing all unnecessary JBoss Tools plugins. The error occurs when the plugin "JBoss Maven CDI Configurator" is installed (1.2.0.v20110624-0731-H5-M2)

      The error disappears when the "CDI facet" in Preferences/JBoss Tools/JBoss Maven Integration is disabled.

       

      Kind regards,

      Gonne

        • 1. Re: Problem with Plugin JBoss Maven CDI Configurator 3.3 M2
          Max Rydahl Andersen Master

          Got a stack trace in the error log ?

           

          Seems like you got different/mismatching versions of ejb's and web facets configured.

          • 2. Re: Problem with Plugin JBoss Maven CDI Configurator 3.3 M2
            Gonne Martens Novice

            eclipse.buildId=I20110613-1736

            java.version=1.6.0_23

            java.vendor=Sun Microsystems Inc.

            BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE

            Framework arguments:  -showlocation -product org.eclipse.epp.package.jee.product

            Command-line arguments:  -os win32 -ws win32 -arch x86_64 -showlocation -product org.eclipse.epp.package.jee.product

             

            Error

            Mon Jul 04 17:19:04 CEST 2011

            An internal error occurred during: "Updating Maven Configuration".

             

            java.lang.RuntimeException: Cannot compare versions of different facets to each other. Attempted to compare version 3.1 of facet jst.ejb with version 2.5 of facet jst.web.

                at org.eclipse.wst.common.project.facet.core.internal.ProjectFacetVersion.compareTo(ProjectFacetVersion.java:506)

                at org.jboss.tools.maven.cdi.configurators.CDIProjectConfigurator.installDefaultFacets(CDIProjectConfigurator.java:140)

                at org.jboss.tools.maven.cdi.configurators.CDIProjectConfigurator.configureInternal(CDIProjectConfigurator.java:100)

                at org.jboss.tools.maven.cdi.configurators.CDIProjectConfigurator.mavenProjectChanged(CDIProjectConfigurator.java:115)

                at org.eclipse.m2e.core.internal.project.ProjectConfigurationManager.mavenProjectChanged(ProjectConfigurationManager.java:753)

                at org.eclipse.m2e.core.internal.project.registry.ProjectRegistryManager.notifyProjectChangeListeners(ProjectRegistryManager.java:724)

                at org.eclipse.m2e.core.internal.project.registry.ProjectRegistryManager.applyMutableProjectRegistry(ProjectRegistryManager.java:847)

                at org.eclipse.m2e.core.internal.project.registry.ProjectRegistryManager.refresh(ProjectRegistryManager.java:280)

                at org.eclipse.m2e.core.internal.project.ProjectConfigurationManager.updateProjectConfiguration(ProjectConfigurationManager.java:280)

                at org.eclipse.m2e.core.ui.internal.UpdateConfigurationJob.runInWorkspace(UpdateConfigurationJob.java:87)

                at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)

                at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

            • 3. Re: Problem with Plugin JBoss Maven CDI Configurator 3.3 M2
              Max Rydahl Andersen Master

              Please open jira with this info at https://jira.jboss.org/jira/browse/JBIDE and provide steps to reproduce if you can.

               

              thanks!