0 Replies Latest reply on Jul 8, 2011 4:18 AM by Sascha Janz

    Performance Rendering Time

    Sascha Janz Master

      i use Richfaces 3.3.3 and Seam 2.2

       

      To investigate performance i wrote a quite simple app build on seamgen, without any functionality

       

      the page is loaded in about one second but "onload" takes 3,5 seconds.

       

      why? what is happening?

       

      is use firefox and yslow tho check that. the results are in the screenshot.

       

      the page is

       

       

      <!DOCTYPE composition PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

          "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

      <ui:composition xmlns="http://www.w3.org/1999/xhtml"

          xmlns:s="http://jboss.com/products/seam/taglib"

          xmlns:ui="http://java.sun.com/jsf/facelets"

          xmlns:f="http://java.sun.com/jsf/core"

          xmlns:h="http://java.sun.com/jsf/html"

          xmlns:rich="http://richfaces.org/rich"

         

          template="layout/template.xhtml">

       

          <ui:define name="head">

      </ui:define>

          <ui:define name="body">

       

              <h1>Seam Binding TestNeu !</h1>

              <rich:panel id="panel">

                         

              </rich:panel>

       

          </ui:define>

      </ui:composition>

       

       

       

      web.xml

       

      <?xml version="1.0" ?>

      <web-app xmlns="http://java.sun.com/xml/ns/javaee"

         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

         xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"

         version="2.5">

       

         <!-- RichFaces -->

       

         <context-param>

            <param-name>org.richfaces.SKIN</param-name>

            <param-value>glassX</param-value>

         </context-param>

       

         <!-- Suppress spurious stylesheets -->

       

         <context-param>

            <param-name>org.richfaces.CONTROL_SKINNING</param-name>

            <param-value>disable</param-value>

         </context-param>

       

         <context-param>

            <param-name>org.richfaces.CONTROL_SKINNING_CLASSES</param-name>

            <param-value>disable</param-value>

         </context-param>

       

         <!-- Change load strategy to DEFAULT to disable sending scripts/styles as packs -->

       

         <context-param>

            <param-name>org.richfaces.LoadStyleStrategy</param-name>

            <param-value>DEFAULT</param-value>

         </context-param>

       

         <context-param>

            <param-name>org.richfaces.LoadScriptStrategy</param-name>

            <param-value>DEFAULT</param-value>

         </context-param>

        

       

         <!-- Seam -->

       

         <listener>

            <listener-class>org.jboss.seam.servlet.SeamListener</listener-class>

         </listener>

       

         <filter>

            <filter-name>Seam Filter</filter-name>

            <filter-class>org.jboss.seam.servlet.SeamFilter</filter-class>

         </filter>

       

         <filter-mapping>

            <filter-name>Seam Filter</filter-name>

            <url-pattern>/*</url-pattern>

         </filter-mapping>

       

         <servlet>

            <servlet-name>Seam Resource Servlet</servlet-name>

            <servlet-class>org.jboss.seam.servlet.SeamResourceServlet</servlet-class>

         </servlet>

       

         <servlet-mapping>

            <servlet-name>Seam Resource Servlet</servlet-name>

            <url-pattern>/seam/resource/*</url-pattern>

         </servlet-mapping>

       

         <!-- Facelets development mode (disable in production) -->

       

         <context-param>

            <param-name>facelets.DEVELOPMENT</param-name>

            <param-value>false</param-value>

         </context-param>

       

         <!-- JSF -->

       

         <context-param>

            <param-name>javax.faces.DEFAULT_SUFFIX</param-name>

            <param-value>.xhtml</param-value>

         </context-param>

       

         <servlet>

            <servlet-name>Faces Servlet</servlet-name>

            <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>

            <load-on-startup>1</load-on-startup>

         </servlet>

       

         <servlet-mapping>

            <servlet-name>Faces Servlet</servlet-name>

            <url-pattern>*.seam</url-pattern>

         </servlet-mapping>

       

         <security-constraint>

            <display-name>Restrict raw XHTML Documents</display-name>

            <web-resource-collection>

               <web-resource-name>XHTML</web-resource-name>

               <url-pattern>*.xhtml</url-pattern>

            </web-resource-collection>

            <auth-constraint/>

         </security-constraint>

       

         <!-- uncomment <ejb-local-ref> entries when deploying to GlassFish and (optionally) JBoss AS 5 -->

         <!--

         <ejb-local-ref>

            <ejb-ref-name>seamtest/AuthenticatorBean/local</ejb-ref-name>

            <ejb-ref-type>Session</ejb-ref-type>

            <local-home/>

            <local>de.loren.seamtest.Authenticator</local>

         </ejb-local-ref>

         -->

       

         <!-- Add entries for each EJB session bean which is also a Seam component (not required on JBoss AS) -->

       

         <persistence-unit-ref>

            <persistence-unit-ref-name>seamtest/pu</persistence-unit-ref-name>

            <persistence-unit-name>../seamtest.jar#seamtest</persistence-unit-name>

            <!-- The relative reference doesn't work on GlassFish. Instead, set the <persistence-unit-name> to "seamtest",

                 package persistence.xml in the WAR, and add a <jar-file> element in persistence.xml with value "../../seamtest.jar".

            <persistence-unit-name>seamtest</persistence-unit-name>

            -->

         </persistence-unit-ref>

       

      </web-app>