8 Replies Latest reply on Aug 25, 2011 8:22 PM by Tobias Wittur

    Human Task Forms (on the fly)

    Tobias Wittur Newbie

      Hi,

       

      I had a look at the humantask example in the jbpm-5.1.0.Final-examples.zip and was able to create a simple workflow with ftl files. However, I would prefer the engine to create the forms on the fly, since a business user would not want to write html by hand.

       

      I had a look at this video:

       

      "Develop complex jBPM processes all in Guvnor? Yes, you can!" : http://vimeo.com/26126678

       

      and realized, there should be a button that creates the forms:

       

      generate task forms.PNG

      The video was submitted 09.07.2011, 2 days after the new designer was released:

       

      I checked the latest version of the designer, which is

      designer-1.0.0.053 2011-07-07

       

      I downloaded the war file and replaced

      C:\jbpm\jboss-5.1.0.GA\server\default\deploy\designer.war with the latest version.

       

      However, I still do not get this buttion. Do I have to do anything else in order to get the new designer running?

      I downloaded the latest jbpm-full-install.zip, and this is still installing the 1.0.0.052 version of the designer.

       

      I also had a look at the evaluation example under

       

      C:\jbpm\sample\evaluation.

       

      I realized that if I add the evaluation.bpmn from eclipse to guvnor, that there are no ftl files ?!

      Also if I check "Other assets, documentation" in guvnor, I can not see any ftl files. So how exactly can the evaluation process work without templates?

       

      When I try to recreate the evaluation process without template files, I always get an error:

       

      org.jboss.resteasy.spi.UnhandledException: java.lang.RuntimeException: Failed to process form template

      java.lang.RuntimeException: Failed to process form template

      ...

      freemarker.core.InvalidReferenceException: employee is undefined.

      ...

       

       

      Best regards and thanks for your help,

       

      Tobias

        • 1. Re: Human Task Forms (on the fly)
          Tihomir Surdilovic Master

          You can replace the designer version in $jbpm_installer/build.properties:

           

          designer.version=1.0.0.053-jboss

          designer.url=http://sourceforge.net/projects/jbpm/files/designer/designer-1.0.0.053/

           

          and run ant clean.demo and ant install.demo for it to get downloaded and copied to the right location.

           

          Also make sure you clear your browser cache before using it again.

           

          If you also want to use the workitem configuration editor shown in that video, you would also now need to clone Guvnor master from https://github.com/droolsjbpm/guvnor and build it with

          -Dfull -DskipTests

          then use the

          guvnor-distribution-wars-5.3.0-SNAPSHOT-jboss-as-5.1.war

           

          Hope this helps.

          1 of 1 people found this helpful
          • 2. Re: Human Task Forms (on the fly)
            Tobias Wittur Newbie

            Thanks Tihomir.

             

            I successfully installed the new version of the designer and the button is there.

            Unfortunately, I could not install the new guvnor yet (git has problems with the proxy). Until I install guvnor, I thought I d play with the new designer.

             

            However, if I click on the new "generate task form template" button, it opens a new browser tab with the following URL, which is completely empty.

            Since the designer is loosely linked with guvnor, I guess the button problem is not linked to the missing latest guvnor version.

             

            http://localhost:8080/designer/taskforms?uuid=915edd09-b2a5-4319-b243-77194dbf23b7&profile=jbpm

             

            No task forms appear under "other assets and documentation".

             

            I tested it on the evaluation example in Firefox 3.6.18 and 5.0.1 as well as IE 8.

             

            IE 8 did not even open the designer:

             

            Webpage error details

            User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)

            Timestamp: Tue, 26 Jul 2011 01:32:35 UTC

             

            Message: Object doesn't support this property or method

            Line: 1977

            Char: 3

            Code: 0

            URI: http://localhost:8080/designer/js/Core/main.js

             

            Message: Object doesn't support this property or method

            Line: 265

            Char: 3

            Code: 0

            URI: http://localhost:8080/designer/js/erdfparser.js

            • 3. Re: Human Task Forms (on the fly)
              Tihomir Surdilovic Master

              The Oryx code was never targeted to IE, but to Firefox. This is because Oryx heavily uses SVG and IE support for SVG was in the past really poor, and afaik still is. If you must use IE at your work for example, best thing to try is to install the Chrome frame for IE (http://code.google.com/chrome/chromeframe/), however I have heard people still having some issues with running Oryx with it installed on IE. My best suggestion is just to stay off IE and use a different browser like FF or Google Chrome.

               

              The URL you are seeing is fine, but it being blank is a concern because even if your process does not have any user tasks, the process form ftl should have been created and displayed (and also stored to guvnor). There seems to be some issues here, are the logs reveiling anything? ($jbpm_installer/jboss-5.1.0.GA/server/default/log/ and look at the server log for errors). Are you running Guvnor on http://localhost:8080? Are you running Guvnor with jaas auth enabled?

              • 4. Re: Human Task Forms (on the fly)
                Tobias Wittur Newbie

                Thanks Tihomir for your reply,

                 

                my guvnor runs on http://localhost:8080/.

                 

                Below the log file output. I guess it is the NilAuthenticator that lets me login with guest instead of admin?!

                 

                I guess the following is the solution? (Had no time to test it yet)

                 

                http://drools.herod.net/drools-guvnor/html_single/index.html#d0e163

                In the components.xml file, you should located a security configuration section like the following:

                 

                <!-- SECURITY CONFIGURATION -->

                <!-- default (will take any username, useful if you want to keep track of users but not authenticate -->

                 

                <security:identity authenticate-method="#{defaultAuthenticator.authenticate}"/>

                 

                <!-- NO authentication. This will bypass the login screen when you hit the app. Everyone is "guest" -->

                 

                <!-- <security:identity authenticate-method="#{nilAuthenticator.authenticate}"/> --> 

                 

                2011-07-27 17:15:52,745 INFO  [STDOUT] (http-localhost%2F127.0.0.1-8080-4) INFO  27-07 17:15:52,744 (NilAuthenticator.java:authenticate:35)

                All users are guests.
                2011-07-27 17:15:52,891 INFO  [STDOUT] (http-localhost%2F127.0.0.1-8080-4) INFO  27-07 17:15:52,891 (NilAuthenticator.java:authenticate:35) All users are guests.
                2011-07-27 17:15:52,947 INFO  [STDOUT] (http-localhost%2F127.0.0.1-8080-4) INFO  27-07 17:15:52,946 (NilAuthenticator.java:authenticate:35) All users are guests.

                2011-07-27 17:15:52,956 INFO  [com.intalio.web.server.TaskFormsServlet] (http-localhost%2F127.0.0.1-8080-1) check connection response code: 204

                2011-07-27 17:15:52,969 INFO  [STDOUT] (http-localhost%2F127.0.0.1-8080-4) INFO  27-07 17:15:52,969 (NilAuthenticator.java:authenticate:35) All users are guests.

                2011-07-27 17:15:52,972 INFO  [com.intalio.web.server.TaskFormsServlet] (http-localhost%2F127.0.0.1-8080-1) create connection response code: 405

                2011-07-27 17:15:52,989 INFO  [STDOUT] (http-localhost%2F127.0.0.1-8080-4) INFO  27-07 17:15:52,989 (NilAuthenticator.java:authenticate:35) All users are guests.

                2011-07-27 17:15:52,997 INFO  [com.intalio.web.server.TaskFormsServlet] (http-localhost%2F127.0.0.1-8080-1) check connection response code: 204

                2011-07-27 17:15:53,002 INFO  [STDOUT] (http-localhost%2F127.0.0.1-8080-4) INFO  27-07 17:15:53,002 (NilAuthenticator.java:authenticate:35) All users are guests.

                2011-07-27 17:15:53,061 INFO  [com.intalio.web.server.TaskFormsServlet] (http-localhost%2F127.0.0.1-8080-1) create connection response code: 405

                • 5. Re: Human Task Forms (on the fly)
                  Tihomir Surdilovic Master

                  If you deploy designer as exploded war in jboss, look at $jboss/server/default/deploy/designer.war/profiles/jbpm.xml, specifically:

                   

                  <stencilsetextension

                        namespace="http://oryx-editor.org/stencilsets/extensions/bpmncosts-2.0#" />

                      <externalloadurl protocol="http" host="localhost:8080" subdomain="drools-guvnor/org.drools.guvnor.Guvnor/oryxeditor" usr="admin" pwd="admin"/>

                   

                  here you can manipulate the protocol, host, the username and password for all guvnor internactions (no need to mess with the subdomain). If you are using the default nil authentication then any username and password combination should work fine.

                  Are your forms still being generated even tho the form generation page that shows after you click on the toolbar button is blank (check in guvnor under other assets and documentation in your package).

                  • 6. Re: Human Task Forms (on the fly)
                    Tobias Wittur Newbie

                    Unfortunately, no forms are generated in my package under "assets and documentation".

                     

                    My console automatically logs me in as guest. In user permissions under administration I granted my guest administrator rights, but it didnt change anything.

                     

                    The following settings are still the standard settings that are currently in place.

                     

                    C:\Tobias\jbpm\jboss-5.1.0.GA\server\default\deploy\admin-console.war\components.xml


                    <!-- security stuff -->

                    <security:identity authenticate-method="#{authenticator.authenticate}"

                    jaas-config-name="jmx-console"/>

                     

                    C:\jbpm\jboss-5.1.0.GA\server\default\deploy\designer.war\profiles\jbpm.xml

                     


                    <stencilsetextension

                    namespace="http://oryx-editor.org/stencilsets/extensions/bpmncosts-2.0#" />

                    <externalloadurl protocol="http" host="localhost:8080" subdomain="drools-guvnor/org.drools.guvnor.Guvnor/oryxeditor" usr="admin" pwd="admin"/>
                    • 7. Re: Human Task Forms (on the fly)
                      Tihomir Surdilovic Master

                      Not sure why you are modifying C:\Tobias\jbpm\jboss-5.1.0.GA\server\default\deploy\admin-console.war\components.xml.

                      Can you show me your components xml of Guvnor? $jboss/server/default/deploy/drools-guvnor.war/WEB-INF/components.xml ?

                      Can you log into Guvnor with admin/admin?

                      • 8. Re: Human Task Forms (on the fly)
                        Tobias Wittur Newbie

                        It works in Version: 1.0.0.054.